1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Interior and rear right brake light and indicator not working

Discussion in 'A3/S3/Sportback (8P Chassis)' started by plymouthaudi, Feb 13, 2013.

  1. plymouthaudi
    Offline

    plymouthaudi Member

    Joined:
    Jan 16, 2012
    Messages:
    88
    Likes Received:
    0
    [Feb 13, 2013]
    Hi everyone just come on here to get abit of advice. I get into the car today it's an a3 tdi 170. And put the ignition on and my rear right brake light and rear right indicator lamp blown lamps are lit and also my interior lights are not working when the doors are open. But the work on the manual setting. I have checked the micro switch on the doors. (It's a 3dr) and once open they show on the dash as being open. I'm so confused any help would be appreciated. Also there is no moisture anywhere inside the car. Thanks to everyone I advance. Luke
    #1
  2. Ads

    Ads

    [Dec 26, 2014]

  3. plymouthaudi
    Offline

    plymouthaudi Member

    Joined:
    Jan 16, 2012
    Messages:
    88
    Likes Received:
    0
    [Feb 13, 2013]
    Also forgot to mention I have changed the lamps as well but not luck. :( not looking like a cheap fix.
    #2
  4. A3Kent
    Offline

    A3Kent Different Gear

    Joined:
    May 16, 2012
    Messages:
    1,341
    Likes Received:
    149
    [Feb 13, 2013]
    Have you checked the fuses?
    #3
  5. plymouthaudi
    Offline

    plymouthaudi Member

    Joined:
    Jan 16, 2012
    Messages:
    88
    Likes Received:
    0
    [Feb 13, 2013]
    checked all fuses they are fine I'm thinking maybe a control unit or a bad earth somewhere but not sure. Thanks for the quick reply :).
    #4
  6. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,510
    Likes Received:
    1,274
    [Feb 13, 2013]
    When you say you've checked the microswitch, which one as the door locks have 3 inside the actual lock.

    Ideally you need to scan with vcds to ascertain what its logged?
    #5
  7. plymouthaudi
    Offline

    plymouthaudi Member

    Joined:
    Jan 16, 2012
    Messages:
    88
    Likes Received:
    0
    [Feb 13, 2013]
    I checked them as far as opened the doors both sides and they show on the dash computer as opened, I didn't realise there are 3 inside the mechanism. So complicated. all fuses checked. I will scan with vcds in the morning. Thanks for the reply.
    #6
  8. plymouthaudi
    Offline

    plymouthaudi Member

    Joined:
    Jan 16, 2012
    Messages:
    88
    Likes Received:
    0
    [Feb 14, 2013]
    All sorted found a plug loose underneath the steering column plug E i think it was. Reset on VCDS and now working lovely including the interior light. Thanks NHN and A3kent for the replies.
    Last edited: Feb 14, 2013
    #7

Share This Page