1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Indicators playing up - relay?

Discussion in 'A3/S3 Forum (8L Chassis)' started by The Doctor, Jan 12, 2012.

  1. The Doctor
    Offline

    The Doctor Well-Known Member

    Joined:
    Jul 25, 2009
    Messages:
    1,252
    Likes Received:
    99
    Hi chaps,

    For some time now my indicators have been a bit temperamental - sometimes they flash fine, other times they have been flashing erratically (that's erratically, not erotically). Anyway, this week I've noticed that they now actually stop working after about 5-6 flashes, even if the indicator stalk is still in the correct position. Turning them off and on again solves the problem for another 5-6 flashes.

    I think this may be the hazard relay - any thoughts/advice on this one? Anyone had the same problem?
    #1
  2. Nilz
    Offline

    Nilz Defo worth the wait :)

    Joined:
    Apr 9, 2006
    Messages:
    10,217
    Likes Received:
    389
    Hey Paul

    Hope you are well mate...

    It sounds much like the hazard relay that has gone, I did mine a while ago, cost about £30-40.

    It doesnt take much to replace either....

    You may need to remove your stereo and prise the whole hazard unit out, then just click the new one in place...job done :)

    Oh and I had the same symptoms as you.
    #2
  3. Arrkon
    Offline

    Arrkon Midlands regional Moderator

    Joined:
    Oct 8, 2010
    Messages:
    1,693
    Likes Received:
    75
    Good to see you again matey :)

    But Uh oh... Getting turned on by flashers lol...

    In all seriousness, It will either be the flasher relay or the stalk. Contacts in both can wear and cause issues like this.
    #3
  4. Rogue-24-84
    Offline

    Rogue-24-84 Member

    Joined:
    Sep 26, 2011
    Messages:
    268
    Likes Received:
    7
    sounds exactly the same as a problem i had with my old 18t, was the hazard light switch.. got a new one from audi fitted it and never went wrong again, abit fidely as its actually attached to the back of the hazard light button itself, but it'l sort it bud 99.9% sure
    #4
  5. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,578
    Likes Received:
    270
    Hazard switch for deff. It has 2 relays in it, one for hazards and one for indicators.

    It's why your hazards probably still work. iirc there is a later one than the std fitted unit and it's sub £40.

    Laterz
    #5
  6. george_seamons
    Offline

    george_seamons Member

    Joined:
    Feb 3, 2010
    Messages:
    35
    Likes Received:
    0
    I have one spare from my track car if its any use to you? From an X reg A3.
    #6
  7. The Doctor
    Offline

    The Doctor Well-Known Member

    Joined:
    Jul 25, 2009
    Messages:
    1,252
    Likes Received:
    99
    OK thanks chaps, that's what I suspected. I think I've seen a guide for the hazard relay replacement on here somewhere so will have a search, unless anyone has the link to that thread handy?

    Mark - yes the hazards are fine.

    I'll get myself a new one for that price, but thanks for the offer george_seamons.
    #7
  8. Martin82
    Offline

    Martin82 Member

    Joined:
    Nov 16, 2011
    Messages:
    73
    Likes Received:
    2
    I had this as my indicators were intermittent sometimes and only one side of the hazards worked, replaced the hazard switch and all was well.

    Mines a pre facelift s3 but i did it like this:

    Drop ashtray (1 screw in the centre)
    Remove stereo
    Remove 2 screws from where stereo was
    pull facia out and drop out of the way just enough.
    Hand into where the stereo was, couple of fingers up into the gap behind the hazard switch and push with a bit of force and out it pops.
    #8
  9. jimmp
    Offline

    jimmp Member

    Joined:
    Feb 5, 2009
    Messages:
    146
    Likes Received:
    0
    Crikey!

    I didn't have to remove the stereo! I just got off the faceplate over the ESP & cupholder and then it was accessible...

    You guys got aftermarket head-units, yeah?
    #9
  10. Snuff
    Offline

    Snuff satan's driver

    Joined:
    Aug 5, 2011
    Messages:
    56
    Likes Received:
    1
    my indicators have just packed in too , i hope i dont have to remove the standard head unit. is there a how to guide on removal
    #10
  11. pioneer181
    Offline

    pioneer181 Torque talks

    Joined:
    Nov 2, 2009
    Messages:
    61
    Likes Received:
    1
    This happened to me today as well. Wouldn't work at all. Then worked if I pushed the stalk a little harder than normal, but only indicated left regardless of which way I was trying to indicate. Thanks for everyones replies as I would of guessed it was the stalk.
    #11
  12. The Doctor
    Offline

    The Doctor Well-Known Member

    Joined:
    Jul 25, 2009
    Messages:
    1,252
    Likes Received:
    99
    #12
  13. neil.c
    Offline

    neil.c Senior

    Joined:
    Apr 9, 2004
    Messages:
    566
    Likes Received:
    1
    Mine has just packed up too, it has been playing up on and off for a while, I wizzed it out before tea, a tap seemed to start it up every time it jammed. I have cleaned up the contacts and adjusted the common pole to be more central, it now seems to be working again so we shall see how it goes :)
    #13
  14. Gops
    Offline

    Gops 6th gear @7000rpm

    Joined:
    Nov 6, 2009
    Messages:
    2,641
    Likes Received:
    286
    Mine stopped flashing then I put the hazards on and it's worked ever since lol. If its not entirely broke then it's a gooden :)
    #14
  15. voorhees
    Offline

    voorhees Moderator Staff Member Moderator

    Joined:
    Dec 18, 2005
    Messages:
    15,027
    Likes Received:
    1,148
    Ha !
    Yeah kid yourself it's not going to happen to your car,I did and guess what ? Two weeks later kaputt
    #15
  16. Nilz
    Offline

    Nilz Defo worth the wait :)

    Joined:
    Apr 9, 2006
    Messages:
    10,217
    Likes Received:
    389
    LOL!!!

    Gops, give it some time..my bet is on the way back from AITP tomorrow ;)
    #16
  17. Gops
    Offline

    Gops 6th gear @7000rpm

    Joined:
    Nov 6, 2009
    Messages:
    2,641
    Likes Received:
    286
    Lol well it's been ok for a month now. I know it'll happen soon, just hoping the car gods like me and keep it working till I can be bothered to get one. Dont jinx me nilz :(
    #17
  18. Nilz
    Offline

    Nilz Defo worth the wait :)

    Joined:
    Apr 9, 2006
    Messages:
    10,217
    Likes Received:
    389
    Sorry bro.xxx

    Im sure it will be fine :)
    #18

Share This Page