1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Indicators- Help Needed Please!!!!

murph Mar 8, 2007

  1. murph

    murph Member

    95
    0
    6
    Hope someone out there can help.

    When I turn on my indicators right or left they seem to have a mind of their own. They flash at different speeds and the noise is louder than normal. However, the green arrows on the dash board stay at a constant speed.

    I’ve turned on my hazard light to see if the problem occurs here, however all is fine and the lights work perfectly. The problem only occurs when indicating.

    Does anyone have an idea what’s wrong and how I go about fixing it?

    Cheers
    Murph
     
  2. jojo

    jojo Looking for Boost! Staff Member Moderator Team Daytona Audi S3 quattro Audi A6 Audi Avant Owner Group

    28,859
    3,518
    113
    If they are flashing faster than normal, check for blown bulbs. If it's something else, you may need a new hazard light switch where the indicator relay is built into...
     
  3. murph

    murph Member

    95
    0
    6
    Just been quoted £40 for a new hazard switch from the stealers. Does anyone know any other places I can get one from.
     
  4. ChriS3

    ChriS3 hud at ye bam

    2,239
    27
    38
  5. murph

    murph Member

    95
    0
    6
    I have managed to pull out the head unit and remove the cover allowing access to the hazard switch. Is it a case of pulling at the switch or do I need to remove anything else first?
     

Share This Page