1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Indicators- Help Needed Please!!!!

Discussion in 'A3/S3 Forum (8L Chassis)' started by murph, Mar 8, 2007.

  1. murph
    Offline

    murph Member

    Joined:
    Jul 30, 2006
    Messages:
    95
    Likes Received:
    0
    Hope someone out there can help.

    When I turn on my indicators right or left they seem to have a mind of their own. They flash at different speeds and the noise is louder than normal. However, the green arrows on the dash board stay at a constant speed.

    I’ve turned on my hazard light to see if the problem occurs here, however all is fine and the lights work perfectly. The problem only occurs when indicating.

    Does anyone have an idea what’s wrong and how I go about fixing it?

    Cheers
    Murph
    #1
  2. jojo
    Online

    jojo S3 Drift King! Staff Member Moderator

    Joined:
    Sep 4, 2003
    Messages:
    25,927
    Likes Received:
    1,559
    If they are flashing faster than normal, check for blown bulbs. If it's something else, you may need a new hazard light switch where the indicator relay is built into...
    #2
  3. murph
    Offline

    murph Member

    Joined:
    Jul 30, 2006
    Messages:
    95
    Likes Received:
    0
    Just been quoted £40 for a new hazard switch from the stealers. Does anyone know any other places I can get one from.
    #3
  4. ChriS3
    Offline

    ChriS3 hud at ye bam

    Joined:
    Jan 25, 2006
    Messages:
    2,235
    Likes Received:
    12
  5. murph
    Offline

    murph Member

    Joined:
    Jul 30, 2006
    Messages:
    95
    Likes Received:
    0
    I have managed to pull out the head unit and remove the cover allowing access to the hazard switch. Is it a case of pulling at the switch or do I need to remove anything else first?
    #5

Share This Page