1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Indicator ticker gone crazy!

Discussion in 'A6/S6/Allroad forum (C5 Chassis)' started by Omniquito, Sep 23, 2012.

  1. Omniquito
    Offline

    Omniquito Member

    Joined:
    Sep 3, 2012
    Messages:
    55
    Likes Received:
    0
    [Sep 23, 2012]
    I was driving to work the other morning when my all roads indicator ticker started to go a little crazy, ticking randomly for about 30 seconds after the indicators were disengaged!

    No indicators would flash, and the green arrows weren't flashing either but the ticker noise was going crazy after indicating in either direction.

    What's going on?! Lol

    Cheers, Neil
    #1
  2. Ads

    Ads

    [Nov 22, 2014]

  3. deanosabby
    Offline

    deanosabby Member

    Joined:
    Sep 16, 2011
    Messages:
    126
    Likes Received:
    13
    [Sep 24, 2012]
    You need a new hazard warning switch as the indicator relay is fitted to the back of it.
    Had the same thing happen last year swapped it out and problem solved.
    #2
  4. Omniquito
    Offline

    Omniquito Member

    Joined:
    Sep 3, 2012
    Messages:
    55
    Likes Received:
    0
    [Sep 24, 2012]
    You are a legend!
    Thank you, i will do that at the weekend :)
    #3
  5. TwistedMind
    Offline

    TwistedMind Long Live The A6

    Joined:
    Jan 24, 2011
    Messages:
    115
    Likes Received:
    0
    [Sep 29, 2012]
    Yes it will be the relay insite the hazzard switch. Known problem. Ebay or main dealer.
    #4

Share This Page