1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

indicator problem

s4mark Nov 27, 2012

  1. s4mark

    s4mark Member

    271
    4
    18
    Hi all. Just drove home from work and noticed all of a sudden that my indicators have a mind of their own. At first they flash normally, then flash fast and then stop all together until I cancel them and try again just for the same thing to happen.. Seems to do it in both directions. Hazards seem to work fine. Would this just be the stalk itself or a relay?
    Cheers, any advice appreciated. I am so close to taking this car to Beachy Head and forgetting to put the handbrake on lol
     
  2. s3 Hoggy

    s3 Hoggy Whats going on???

    1,689
    129
    63
    Hazard switch relay,

    easy cheap fix
     
  3. s3 Hoggy

    s3 Hoggy Whats going on???

    1,689
    129
    63
    [FONT=.HelveticaNeueUI]http://www.audi-sport.net/vb/a3-s3-forum-8l-chassis/77916-removing-hazard-button.html[/FONT]
     
  4. s4mark

    s4mark Member

    271
    4
    18
    Thanks mate. Assumed as the hazards worked fine then it would be the stork which looks like a pig to change. I will get a new hazard relay and give it a go. Thanks again
     
  5. s3 Hoggy

    s3 Hoggy Whats going on???

    1,689
    129
    63
    Well your symptoms are exactly the same what I had mate, they got worse and worse untill they just gave up
     
  6. s4mark

    s4mark Member

    271
    4
    18
    Im so glad otherwise would have just bought a stalk and spent all tomorrow removing the airbag and steering wheel to replace something for no reason! Thats why I love this site so much, good reason to keep buying audi's !!!
    Cheers
     
  7. Welly

    Welly VX220 SC Driver :)

    10,696
    126
    38
    I have also seen this be the physical hazard switch before.
     

Share This Page