1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Indicator isuues

notfastwes Dec 18, 2013

  1. notfastwes

    notfastwes New Member

    18
    1
    1
    In the last couple of days the indicators have developed a fault.
    When I indicate (either way) it will blink three then stop. That's with the stalk still in the indicate position. I am having to flick it off and on again where it will do the same.

    Will this be a relay issue or is the fault at the stalk?
     
  2. myth

    myth Member

    157
    6
    18
    I believe it's the stalk, for not sending the correct signal to the relay. Try spraying some contact cleaner where the stalk pivots. It that doesn't work, you need to remove the stalk and repair it, or replace it.
     
  3. notfastwes

    notfastwes New Member

    18
    1
    1
    I now believe it to be relay . While driving today when it happened I tapped the area around the hazard button and the indicator started working. I still had to do this every time I indicated though which is a bit of a pain.
    Will scan it when I have more time.
     
  4. elan2s

    elan2s Active Member

    344
    40
    28
    Fairly common fault on C5s and not a difficult one to repair. The indicator relay is part of the hazard switch. There are a number of "how toe" on the Internet, but basically you remove the piece of trim around the switch and then use a pair of pointed pliers to pull the switch out. Pop the new one in and then clip the trim back on.
     

Share This Page