1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

idle up and down and flat spots

Discussion in 'A3/S3 Forum (8L Chassis)' started by gumball b, Apr 3, 2010.

  1. gumball b

    gumball b [OLD SKOOL CRUISER]

    Joined:
    Oct 11, 2009
    Messages:
    72
    Likes Received:
    1
    hi everyone,been ofline for a while. i was hoping i can get a reply to my :s3addict:it also has an unpredictable flat spot when you dont need it,its like it surges all of a sudden.i put a k+n panel filter in about a month ago and could this be the cause,im fitting a forge 007p tommorow to it and hope this may cure it a bit,i know the bosh one is not up to scratch..any advice from anyone i would be most greatful many thanks and good to be back....:crying:
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. Sandip

    Sandip Well-Known Member

    Joined:
    Nov 7, 2006
    Messages:
    2,427
    Likes Received:
    79
    Hi bud, to check if your maf is faulty, unplug it and see if the idle is any better, if it idle ok with the maf unplugged you need to replace it. The k&n has probably caused it to go
     
  4. gumball b

    gumball b [OLD SKOOL CRUISER]

    Joined:
    Oct 11, 2009
    Messages:
    72
    Likes Received:
    1
    thanks for that mate,if it is that it will do it again i suppose if i have to get a new one. someone said to me not to do it coz of oil residue getting stuck to the maf, will try that tommorow,still gonna fit the d/v though hope that goes ok thanks again mate....
     
  5. Sandip

    Sandip Well-Known Member

    Joined:
    Nov 7, 2006
    Messages:
    2,427
    Likes Received:
    79
    I had a k&n in mine didn't cause any issues, you could clean it first and see how it goes. It might be worth getting it checked via vagcom, might have other faults on it
     

Share This Page