1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to transfer Music from iTunes to SD card for the car?

Tom75 Aug 14, 2013

  1. cemerson

    cemerson Well-Known Member

    4,244
    950
    113
    Artwork is all in place now... just applying them to the tags in the files, taking quite a while!

    Bet it doesn't work after all this :p Each cover is identically sized though, all in the same format, so I can write a script to change the sizes and re-import everything into the tags easily enough if I need to.
     
  2. felsby

    felsby Member

    53
    12
    8
    hello everybody
    I have some months´ experience with SD cards in my A3. I just upgraded from 32 to 128Gb and now have access to my complete CD collection in 320kbps AAC. MMI will NOT play lossless files, but the audible difference between 320 and lossless is really hard to detect! I would NOT take a bet after two beers.
    Cover art: I have not made tests, but it seems that only cover art uploaded in 300x300 pixels or less are shown on the MMI screen - and only in the "reduced display" option.
    Drawback: Apple users copying their iTunes music files onto an SD card will be able to see hidden OS X non-audio files on-screen. A few minutes playing geek with the "Terminal" program sorts this out. I can post a quick guide if so desired.
     
    Tom75 likes this.
  3. cemerson

    cemerson Well-Known Member

    4,244
    950
    113
    All my 800x800 artwork is working fine in both views - Think it depends on whether you have the tech pack or not. 500x500 is the maximum in the manual for non tech pack.
     
    Tom75 likes this.
  4. felsby

    felsby Member

    53
    12
    8
    OK, that explains it. I guess the "tech pack" is the UK designation for what danes and germans call "MMI plus" with a larger screen, touch surface on the rotary knob and internal hard drive.
     
  5. cemerson

    cemerson Well-Known Member

    4,244
    950
    113
    Yes, basically.
     
  6. BigD289

    BigD289 Member

    104
    13
    16
    I downloaded an app called Clean Media which removes the OSX hidden files before ejecting. Works quite well, but did cost £0.69!
     
    felsby likes this.
  7. BigD289

    BigD289 Member

    104
    13
    16
    mjcourtney likes this.
  8. Tom75

    Tom75 Member

    92
    14
    8
    I have now transferred my music collection to SD from mac using the folder system discussed above, meaning one folder for each artist and then the albums in sub folders.
    This system works great when you do folder browsing however the MMI is a little confused when you browse by albums meanings its a little messy because some albums are shown several times and I thing its because if there are songs featuring another artist etc.

    have to play around a little and see what I find out.

    Regards,
    Tom
     
  9. Tom75

    Tom75 Member

    92
    14
    8
    Hi again guys,

    I have on my SD card everything stored in folders for artists and sub folders for albums and for some reasons the album artwork is not showing correctly for some of the albums and I have album artwork for every album stored and all artwork is the same format and size. Does anybody have an explanation for that?

    If there is an album for which the MMI does not show the correct artwork then it chooses a general artwork called for example "sould music" with a general picture. Why is that and what can I do about it?

    Regards,
    tom
     
  10. cemerson

    cemerson Well-Known Member

    4,244
    950
    113
    The default artwork probably comes from the genre in the ID3 tag
     
  11. Tom75

    Tom75 Member

    92
    14
    8
    That could be but why does it not use some of the covers in album folders? Its working with most of them and I cannot see any difference to the ones where it doesn´t work.

    Regards,
    tom
     
  12. cemerson

    cemerson Well-Known Member

    4,244
    950
    113
    Not sure - all works with mine. Are you sure they are all exactly 800x800, and not something like 800x799?
     
    Tom75 likes this.
  13. Alan_JB

    Alan_JB New Member

    6
    2
    3
    I had the same issue - some cover art was not displaying even after setting them to be 500x500 pixels.

    Eventually found the reason hidden away in the MMI manual - it mentions that each cover art jpg/png file also has to be less than 200kb in size. Using mp3tag I found my missing cover art files were larger than this. Reloaded them as smaller files and they all now work for me.
     
    Tom75 likes this.
  14. cemerson

    cemerson Well-Known Member

    4,244
    950
    113
    Wonder if the same restriction applies to the tech pack ones? Or a different limit?
     
  15. Alan_JB

    Alan_JB New Member

    6
    2
    3
    The standard MMI manual mentions it in the Meta data section of the "Supported media and file formats" table - maybe there a similar section in the Tech pack MMI manual, if there is one?
     
  16. cemerson

    cemerson Well-Known Member

    4,244
    950
    113
    Yep - will have a look tomorrow if I remember
     
  17. Tom75

    Tom75 Member

    92
    14
    8
    Thanks for your input, I have converted all to 300 by 300 but now that you said this, do they have to be exactly square? It might be that some are maybe 300 x 290 or so? I will check that and let you know if that was the reason.

    Alan B: they are definitely all below 200kb so there I should be ok.

    Have to do some more testing.

    Regards,
    tom
     
  18. cemerson

    cemerson Well-Known Member

    4,244
    950
    113
    I think from what I was trying to work out with mjcourtney before I got my car (he kindly tried out some of my files in his car to check the artwork), they have to be square, but not totally certain. Worth some experimentation.
     
  19. Tom75

    Tom75 Member

    92
    14
    8
    Ok, I have checked this and all files are perfectly square, meaning the same amount of pixels horizontal and vertical and all are below 200kb,......... but still most are working and some don´t and I cannot see any difference to the ones that are displayed correctly. Seems to be some mystery.

    Any other ideas?

    Regards,
    Tom
     
  20. cemerson

    cemerson Well-Known Member

    4,244
    950
    113
    Are they all definitely jpg, and not png/gif/bmp or something?
     
  21. Tom75

    Tom75 Member

    92
    14
    8
    yes, they are
     
  22. cemerson

    cemerson Well-Known Member

    4,244
    950
    113
    Not sure then I'm afraid, unless there's something weird about the way they've been embedded into the tag
     
  23. Alan_JB

    Alan_JB New Member

    6
    2
    3
    Hi Tom, not sure what else to suggest...apart from I notice you are using a Mac as I do - I sorted out most issues with cover art etc by using a version of mp3tag that runs on the Mac - it can be downloaded here http://dl.dropbox.com/u/6229594/Mp3tag-v2.57.app.zip

    I used that to directly look at the files on the SD card and update the cover art/tags etc on the files that weren't displaying correctly - might be worth a go if you still have problems.
     
  24. glospete

    glospete Well-Known Member Team Ibis Team Glacier Audi A3 Audi TT

    1,341
    817
    113
    Hi
    This Dropbox link seems not to be active any more. Do you have another link please for the Mac version as I didn't know this was available.
     
  25. Alan_JB

    Alan_JB New Member

    6
    2
    3
    glospete likes this.
  26. glospete

    glospete Well-Known Member Team Ibis Team Glacier Audi A3 Audi TT

    1,341
    817
    113

Share This Page