1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

'How to' photo guide - replacing your Fuel Temperature Sensor on the 2.0 TDi BRD

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by Richardesty, Jul 26, 2012.

  1. Richardesty

    Richardesty loves quattro

    Joined:
    Oct 10, 2008
    Messages:
    750
    Likes Received:
    17
    As the title says - here's a quite 'How to' photo guide - replacing your Fuel Temperature Sensor on the 2.0 TDi BRD engine.

    I've recently replaced mine having done some reading up on here, thought it may be the cause of some recent starting issues and general 'rough' running. That said, my temp gauge was always reading normal at just under 90c.

    Here's how I did it....

    1 - buy the replacement sensor and o-ring - I went for an OEM version from my local Audi Dealer:

    [​IMG]

    2 - open your bonnet (see instruction manual):

    [​IMG]

    3 - remove the engine cover - it just lifts off with some firm upward pressure:

    [​IMG]

    4 - locate the existing Fuel Temperature Sensor - on a high level hose at the rear of the engine bay, adjacent to the battery:

    [​IMG]

    5 - un-clip the electrical connector:

    [​IMG]

    6 - remove the clip which holds the sensor in place - carefully prize it away with a flat screwdriver:

    [​IMG]

    7 - pull the sensor away from the 'holder' noting that the original o-ring may stay in the hole (remove this too). The new one is on the left.
    Then clean the opening with a cloth:

    [​IMG]
    [​IMG]

    8 - push the new sensor and o-ring into the hole, and replace the green clip:

    [​IMG]

    9 - Replace the electrical connector, then start the engine to test for leaks.

    10 - Replace the engine cover and close the bonnet.

    Having done a few runs it seems to have cured my starting problems and smoothed out the power delivery.

    Not bad for £38 and about 4 minute work, including taking the photos!

    Rich
     
    #1 Richardesty, Jul 26, 2012
    Last edited by a moderator: Aug 9, 2012
    tr3m5 likes this.
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. Wrath

    Wrath Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    1,190
    Likes Received:
    41
    Nowt showed in VCDS?
     
  4. Richardesty

    Richardesty loves quattro

    Joined:
    Oct 10, 2008
    Messages:
    750
    Likes Received:
    17
    Not a dickie bird.....and it was serviced a month or so ago and Audi didn't report any issues, even though I asked them to check out the rough idle and poor starting.
     
    Baz8878 likes this.
  5. mm707

    mm707 Member

    Joined:
    Mar 26, 2011
    Messages:
    250
    Likes Received:
    6
    Richard - Was yours difficult to start only the first time or at anytime after that also. I ask because mine ticks over a bit rough and the first start is always slow - after that it starts fine for the rest of the day. If your symptoms were the same I'll give this a go. Thanks
     
  6. Richardesty

    Richardesty loves quattro

    Joined:
    Oct 10, 2008
    Messages:
    750
    Likes Received:
    17
    Yeah pretty much so, although some first starts were worse than other and therefore needed a second attempt #embarassing
     
  7. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,394
    Likes Received:
    623
    nice guide just changed mine
    couldnt find the lil fukker
    as it was pointing downwards
    just got mine from TPS £15.98 inc for sensor o-ring and a new clip
     
  8. madstaff

    madstaff Member

    Joined:
    Apr 29, 2012
    Messages:
    81
    Likes Received:
    3
    Is this a 'coolant temperature sensor' or a 'fuel temperature sensor' as it looks as though its fitted in the fuel line??
     
  9. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,394
    Likes Received:
    623
    hmm you have got me thinking now
    cos it stank of Diesel

    **** just checked with a lad at audi is is the FTS
     
    #8 hades-, Aug 6, 2012
    Last edited: Aug 6, 2012
  10. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,394
    Likes Received:
    623
    but both parts are the same
    sois the CTS same part as the FTS ?
     
  11. madstaff

    madstaff Member

    Joined:
    Apr 29, 2012
    Messages:
    81
    Likes Received:
    3
    Its a generic temperature sensor, doesn't matter if its sensing the temperature of diesel or coolant.

    I just wanted to clarify that it was actually the 'fuel temperature sensor' that was being changed.
     
  12. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,394
    Likes Received:
    623
    i was changeing the coolant tem sensor
    but saw this guide
    and thanks for pointing it out iv just changed the sensors back around and ill be puting it in the right place tmoro
    back of the engine where is should go
    and iv done so many on petrols but with it been diesel i just went with the guide
     
  13. madstaff

    madstaff Member

    Joined:
    Apr 29, 2012
    Messages:
    81
    Likes Received:
    3
    Do you know what number measuring block the values for the fuel temp sensor can be found??

    I have a Snap-On Solus which can view measuring blocks but you have to know which number as where to look, there is no actual description.
     
  14. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,394
    Likes Received:
    623
    ill ask my mate tmoro i know hes got a solus so he might know
     
  15. madstaff

    madstaff Member

    Joined:
    Apr 29, 2012
    Messages:
    81
    Likes Received:
    3
    Found it mate so dont worry about it.

    Group 007, Fuel temp - n/a - Intake air temp - Coolant temp
     
  16. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,394
    Likes Received:
    623
    no probs
     
  17. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,394
    Likes Received:
    623
    rich the CTS it to the left of the 1 you did
    and very well hidden
    oh and get someone with skinny arms its a rite ****in killer.
    [​IMG]
     
  18. Richardesty

    Richardesty loves quattro

    Joined:
    Oct 10, 2008
    Messages:
    750
    Likes Received:
    17
    :readit: ******!

    Thanks Bez, I thought it was too easy to be true!!!!

    Ive now located the bleeder and swapped it out - need to top my coolant up as a result tho.

    I'd best re title the thread!
     
  19. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,394
    Likes Received:
    623
    i did it with a hot engine
    and god did i burn my arm
     
  20. Richardesty

    Richardesty loves quattro

    Joined:
    Oct 10, 2008
    Messages:
    750
    Likes Received:
    17
    I didn't want to admit that bit!

    Damn - I can't change the title of the thread.....

    Apologies everyone!
     
  21. quattrojames

    quattrojames Moderator
    Staff Member Moderator Audi A6

    Joined:
    Mar 28, 2008
    Messages:
    13,995
    Likes Received:
    522
    Lol at this thread :lmfao:

    I've edited it, Rich are you happy with how it is now?
     
  22. Google AdSense Guest Advertisement



    to hide this advert.
  23. Richardesty

    Richardesty loves quattro

    Joined:
    Oct 10, 2008
    Messages:
    750
    Likes Received:
    17
    Cheers James, that'll do :respekt:
     
  24. hubbo1

    hubbo1 Member

    Joined:
    May 14, 2012
    Messages:
    96
    Likes Received:
    4
    hi bez
    i still cant find coolant sensor even with the picture! could you give me a bit more detail as to the position?
    thanks
     
  25. GTTeixeira

    GTTeixeira New Member

    Joined:
    Nov 7, 2012
    Messages:
    3
    Likes Received:
    0
    Hi,
    I also have faulty reading on my temperture guage and can't find my CTS on my BRD engine.
    Can anyone help me out?

    Thanks
     
  26. SL11CKK

    SL11CKK Active Member

    Joined:
    Apr 22, 2011
    Messages:
    679
    Likes Received:
    33
    The coolant sensor should have 4pins/wires going into it like mine
     
  27. GTTeixeira

    GTTeixeira New Member

    Joined:
    Nov 7, 2012
    Messages:
    3
    Likes Received:
    0
    is the CTS green?
     

Share This Page