1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How easy is it to retrofit auto lights&wipers?

Discussion in 'A3/S3/Sportback (8P Chassis)' started by boggysv, Feb 2, 2009.

  1. N8
    Offline

    N8 Kowalski Details VCDS Map User

    Joined:
    Jul 4, 2007
    Messages:
    17,163
    Likes Received:
    692
    [Nov 22, 2011]
    I've got glass for the mirrors if anyone is interested
    #41
  2. ADi Nuff Valves
    Offline

    ADi Nuff Valves Member

    Joined:
    Apr 28, 2010
    Messages:
    259
    Likes Received:
    8
    [Dec 1, 2011]
    Kufatec loom has shown up! Now to start trying to get my head around the wiring. :readit:

    Does anyone have parts numbers for the CH/LH connector and repair wires i'll need? I have the auto-light switch with the CH/LH button, just need the connecting half.
    #42
  3. Ash187
    Offline

    Ash187 Audi-Retrofits.co.uk Site Sponsor

    Joined:
    Mar 12, 2009
    Messages:
    6,705
    Likes Received:
    450
    [Dec 1, 2011]
    #43
  4. ADi Nuff Valves
    Offline

    ADi Nuff Valves Member

    Joined:
    Apr 28, 2010
    Messages:
    259
    Likes Received:
    8
    [Mar 2, 2012]
    I have the same problem as what you described below. How did you sort the issue?

    Cheers.

    #44
  5. Ash187
    Offline

    Ash187 Audi-Retrofits.co.uk Site Sponsor

    Joined:
    Mar 12, 2009
    Messages:
    6,705
    Likes Received:
    450
    [Mar 2, 2012]
    that problem with the light/rain sensor was an issue with the power from the fuse box... it was loose :ninja:
    #45
  6. ADi Nuff Valves
    Offline

    ADi Nuff Valves Member

    Joined:
    Apr 28, 2010
    Messages:
    259
    Likes Received:
    8
    [Mar 2, 2012]
    Just to follow up, turned out my earth wasn't happy. Moved the earth to a different bolt and now the auto-dimming rear view mirror and rain-light sensor appear to work.

    I've just tried the auto lights and they seem to stay on all the time. Sounds like you had the same issue in the past and it was more luck and a bit of fiddling that sorted it out! :sorry:
    #46
  7. paul_e88
    Offline

    paul_e88 New Member

    Joined:
    Dec 8, 2008
    Messages:
    25
    Likes Received:
    0
    [Oct 13, 2012]
    Can you tell me which bolt did you take your earth from?

    I'm having the same issues, the DIS is displaying that the light sensor is defective, and on VCDS i have two errors, one about the sensor and another one about the canbus connection.

    My earth is a "splice and join" to an existing earth wire, should i move it to a bolt?
    The thing is that i have 12v at the pins on the rain and light sensor, i checked.

    I would try any possible solution, before having to replace the sensor..i am still hoping that it's not defective.
    Last edited: Oct 13, 2012
    #47
  8. Ash187
    Offline

    Ash187 Audi-Retrofits.co.uk Site Sponsor

    Joined:
    Mar 12, 2009
    Messages:
    6,705
    Likes Received:
    450
    [Oct 13, 2012]
    i use the bolt up just above the steering column to the right above the CE module. if not you could use the OEM grounding point just behind the carpet on the right side of the car behind the bonnet release lever
    #48
  9. RYes3
    Offline

    RYes3 Member

    Joined:
    Apr 19, 2012
    Messages:
    732
    Likes Received:
    84
    [Feb 1, 2013]
    Hi Guy's, so on an OEM install how would these wires be attached? Would they really be spliced too?
    #49
  10. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,477
    Likes Received:
    1,264
    [Feb 2, 2013]
    In what respect spliced, you mean if installed from factory, if so then its all built into the cars original looms, if doing after purchase then new loom added with pins on ends to plum into connectors.
    #50
  11. Stevec83
    Offline

    Stevec83 New Member

    Joined:
    Aug 5, 2014
    Messages:
    3
    Likes Received:
    0
    [Aug 5, 2014]
    Just being curious here :whistle2: how much would this retro fit cost from your good self ?
    #51
  12. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,477
    Likes Received:
    1,264
    [Aug 5, 2014]
    Welcome to the site.

    I'll PM you :)
    #52
  13. Benno72
    Offline

    Benno72 New Member

    Joined:
    Aug 9, 2014
    Messages:
    1
    Likes Received:
    0
    [Aug 9, 2014]
    Could I get a price also please.
    #53
  14. Randomage
    Offline

    Randomage New Member

    Joined:
    Jun 13, 2014
    Messages:
    16
    Likes Received:
    2
    [Aug 9, 2014]
    Semi-related = I bought mine with auto lights, auto dim and leaving/coming home lights (53 plate). No sign of auto wipers....is that normal? :think:
    #54
  15. 3.2 Ju
    Offline

    3.2 Ju Well-Known Member

    Joined:
    Jul 22, 2007
    Messages:
    1,374
    Likes Received:
    82
    [Aug 9, 2014]
    Are you sure? There will be no markings to say, but if you leave the wiper stalk in the intermittent setting, it should work on auto.
    #55
  16. Ash187
    Offline

    Ash187 Audi-Retrofits.co.uk Site Sponsor

    Joined:
    Mar 12, 2009
    Messages:
    6,705
    Likes Received:
    450
    [Aug 9, 2014]
    Yes the older ones didn't have rain sensors. Just a light sensor on the back if the rear view mirror
    #56
  17. 3.2 Ju
    Offline

    3.2 Ju Well-Known Member

    Joined:
    Jul 22, 2007
    Messages:
    1,374
    Likes Received:
    82
    [Aug 9, 2014]
    I'm retrofitting it to mine, can i use any rain sensor as long as it fits into the mirror? The prices on ebay vary a LOT!
    #57
  18. Ash187
    Offline

    Ash187 Audi-Retrofits.co.uk Site Sponsor

    Joined:
    Mar 12, 2009
    Messages:
    6,705
    Likes Received:
    450
    [Aug 10, 2014]
    It should be fine to fit any of those sensors. You may have to upgrade your ce module though.
    Pm me for more info
    #58
  19. 3.2 Ju
    Offline

    3.2 Ju Well-Known Member

    Joined:
    Jul 22, 2007
    Messages:
    1,374
    Likes Received:
    82
    [Aug 10, 2014]
    :icon_thumright:
    #59
  20. hollow
    Offline

    hollow Active Member

    Joined:
    May 19, 2009
    Messages:
    782
    Likes Received:
    45
    [Sep 14, 2014]
    ash i need part no for the rls sensor and light switch so i can order from tps . tried 3 different sensors in a 2009 with led drl xenon lights but with old type ce unit . non of the sensors were recognised .
    #60
  21. Ash187
    Offline

    Ash187 Audi-Retrofits.co.uk Site Sponsor

    Joined:
    Mar 12, 2009
    Messages:
    6,705
    Likes Received:
    450
    [Sep 14, 2014]
    Have you got the wiring correct? as 3 sensors that doesn't work doesn't sound right.
    #61
  22. hollow
    Offline

    hollow Active Member

    Joined:
    May 19, 2009
    Messages:
    782
    Likes Received:
    45
    [Sep 15, 2014]
    think its the sensors tried 2 of them in in laws golf with auto light /wipers both come up with same faults ,think there an incompatabilty issue .
    golf uses the square sensor where it seems the audi uses the round smaller type .

    cant for the life of me get the tt light switch even tps sheffield haven't got stock
    #62
  23. hollow
    Offline

    hollow Active Member

    Joined:
    May 19, 2009
    Messages:
    782
    Likes Received:
    45
    [Sep 15, 2014]
    forgot to ask you ash what part no do you have for the rls sensor your using and which cent electric box revision.
    #63
  24. Ash187
    Offline

    Ash187 Audi-Retrofits.co.uk Site Sponsor

    Joined:
    Mar 12, 2009
    Messages:
    6,705
    Likes Received:
    450
    [Sep 16, 2014]
    I can't remember which sensor i have, they are all roughly the same
    I have the F rev CE module.

    what error message do you get?
    #64
  25. hollow
    Offline

    hollow Active Member

    Joined:
    May 19, 2009
    Messages:
    782
    Likes Received:
    45
    [Sep 16, 2014]
    forgot wording exactly but goes on the lines of no comms with linbus . its definately the rls sensor ,not the wiring .
    its not even recognised by the ce unit or gateway
    either on the audi or the mk5 golf
    Last edited: Sep 16, 2014
    #65

Share This Page