1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Horrible Noise! Steering Rack or Pump?

Discussion in 'A4/S4 forum(B5 Chassis)' started by Hairy Ballbag, Apr 3, 2007.

  1. Hairy Ballbag
    Offline

    Hairy Ballbag Member

    Joined:
    Mar 28, 2007
    Messages:
    59
    Likes Received:
    0
    [Apr 3, 2007]
    My 2.8 Quattro makes a horrible noise when cold! It's steering related but I don't know if it's the pump or the rack...

    Whiney noise that's kind'a rev related but not coming from the engine.
    Steering squeels and farts when the wheels are turned but makes no noise on full lock.

    When the car's warned up, the noise goes.

    Answers on a post card... x
    #1
  2. Ads

    Ads

    [Nov 29, 2014]

  3. Beerzo
    Offline

    Beerzo Masa'warty 3200... Talk To Me!

    Joined:
    Feb 10, 2006
    Messages:
    1,242
    Likes Received:
    0
    [Apr 4, 2007]
    Check the level of your power steering fluid. One of the other boys had a similar problem a week ago and turned out to be power steering fluid.
    #2
  4. Hairy Ballbag
    Offline

    Hairy Ballbag Member

    Joined:
    Mar 28, 2007
    Messages:
    59
    Likes Received:
    0
    [Apr 6, 2007]
    Here's me looking for a bigger problem that I've actually got!
    Tw*t!
    #3
  5. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    32
    [Apr 6, 2007]
    Make sure you only use the VAG mineral oil to top it up with, not any of the generic high street fluid as this can damage the seals inside the system.

    Also, don't want to sound like the voice of doom, but unless you've had work done recently on the steering then it shouldn't lose any fluid.
    Keep an eye on the level as it could be developing a leak, which if it's the rack gets expensive - £800 for a recon unit fitted.
    Hope it isn't, but mine starting in exactly the same way, then I started getting smoke coming from the wheelarch where the fluid was leaking onto something hot underneath and ended up needing a new rack.
    #4

Share This Page