1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hoping someone can help - central locking and windows no longer work!

Discussion in 'A3/S3 Forum (8L Chassis)' started by ptr, Mar 12, 2012.

  1. ptr
    Offline

    ptr Member

    Joined:
    Aug 14, 2010
    Messages:
    128
    Likes Received:
    2
    [Mar 12, 2012]
    This all happened at once, car was perfect then windows, sunroof and remote locking stopped working. I've been googling and searching but have yet to find something displaying these exact symptoms;

    - Central locking no longer works, indicators don't flash, it's like I havent even pressed the button on the key fob.
    - Electric windows and sunroof don't work - again just dead.
    - If I lock with the key, the alarm does arm - ie. flashing red LED on the door
    - If I press the lock button on the driver door nothing happens, no motor noise from the central locking pump.

    VCDS shows a central locking pump leak and nothing else, I've cleared this and it comes back straight away.

    Is this simply a case of replace the central locking pump (as it contains the convenience ECU which controls windows/sunroof as well)? OR is this a wiring issue somewhere as it almost seems like the central locking pump is getting no power or is dead? (I've checked fuses).

    Also, I checked the pump and theres no water or obvious damage around it. Hoses and wiring appear fine.

    Apologies for the long post, really hope someone can point me in the right direction - is it worth replacing the central locking pump first?

    Cheers
    Pete
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. Sandra
    Offline

    Sandra MODERATOR Staff Member Moderator

    Joined:
    Sep 12, 2010
    Messages:
    16,162
    Likes Received:
    2,380
    [Mar 12, 2012]
    Maybe a pm to NHN? :)
    #2
  4. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,908
    Likes Received:
    1,333
    [Mar 12, 2012]
    Do the doors lock with the key and does holding the key in the locking position close the windows/sunroof?

    Scan for fault codes is top of the list...

    <tuffty/>
    #3
  5. krisrg87
    Offline

    krisrg87 Member

    Joined:
    Mar 28, 2011
    Messages:
    70
    Likes Received:
    3
    [Mar 12, 2012]
    I had the exact same problem. I would advise removing the central locking pump, very easy to do. Open it up and and the is a graphite disc/impeller. Mine was shattered and had blown the fuse. Windows/central locking and interior light is all on the same fuse. If it is this part then you can get a repair kit of ebay for £40. Mine works great now. Good Luck
    #4
  6. Jimgrim77
    Offline

    Jimgrim77 Member

    Joined:
    Nov 6, 2011
    Messages:
    959
    Likes Received:
    20
    [Mar 12, 2012]
    +1 on that. Central locking pump. Had to replace mine last week for same reason. Might just need to be vacuumed out though. Try first. Unplug from behind rear passenger side light and dismantle. Don't worry it's only a circuit board and punk etc. if not. eBay for new one. I paid £58, but you'll need someone to reprogrammed the keys to the central locking after install.

    Also, check the fuses. Top right one from memory.
    #5
  7. ptr
    Offline

    ptr Member

    Joined:
    Aug 14, 2010
    Messages:
    128
    Likes Received:
    2
    [Mar 18, 2012]
    In case anyone else has this problem, I got a used central locking pump off eBay for £60 posted, fitted today and everything is working fine!

    Pump runs for approx 2-3 seconds and after clearing the 'pump overrun - likely leak' code it has not returned so no leaks hopefully.

    I had to resynchronise my keys, here's how;

    To clear central locking memory put one of your keys in ignition and turn it on but don't start engine. After that get out of your car and with second key lock your car (not with remote), keep the key in the lock and slowly press the unlock button 5 times on your remote. The indicators should flash each time you press unlock - the memory has now been cleared.

    Open your car with a key and take out the one from the ignition and close car by key. Wait about 1 min and open car, put one of keys in ignition and turn it on but don't start the engine (I've read that you need to remove the fob and just use the key for this, I did, but not sure if it's actually required). Leave this key in the car and get out.

    Lock driver door using the other key (this is the one you're programming) and press the unlock button once with the key still in the lock, the indicator should flash once. Wait 15 seconds then press and hold unlock for confirmation, the car should open. This key is now programmed, remove the other key from ignition to test.

    Do the same for other remote, but when you program this one you have to press unlock twice and again wait 15 sec and press unlock once more to confirm.

    Credit from this forum;
    Audi A3 Key Fob not working !!!!! I just tidied up post #6 to hopefully make it easier to follow.
    #6
  8. Jimgrim77
    Offline

    Jimgrim77 Member

    Joined:
    Nov 6, 2011
    Messages:
    959
    Likes Received:
    20
    [Mar 18, 2012]
    Glad you got it sorted.
    #7

Share This Page