1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HID's flickering

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by QuottroA4, Apr 2, 2011.

  1. QuottroA4
    Offline

    QuottroA4 Member

    Joined:
    Mar 4, 2009
    Messages:
    179
    Likes Received:
    3
    [Apr 2, 2011]
    I have recently had a problem with my HID's flcikering and switching off and on again. This genrally happens when the lights have been on for some time but can happen sooner at times.


    I have recently fitted new bulbs (Osram CBI's) but dont think it is the bulbs as it was doing it before I fitted them, just no so much - or maybe I didnt notice as the old bulbs were quite dim.

    Does anybody know why this is happening? I hope it is not the ballasts as they are very expensive to replace!
    #1
  2. Ads

    Ads

    [Nov 25, 2014]

  3. Woorlord
    Offline

    Woorlord shifting to Hyperspace... . VCDS Map User

    Joined:
    Dec 8, 2007
    Messages:
    949
    Likes Received:
    13
    [Apr 2, 2011]
    Is it both of them at the same time or only one headlight?
    #2
  4. QuottroA4
    Offline

    QuottroA4 Member

    Joined:
    Mar 4, 2009
    Messages:
    179
    Likes Received:
    3
    [Apr 2, 2011]
    Good question, both I think!
    #3
  5. b00zehound
    Offline

    b00zehound Member

    Joined:
    Oct 26, 2008
    Messages:
    86
    Likes Received:
    0
    [Apr 2, 2011]
    I had the same problem. Im sorry to say it was the ballasts. You should be able to pick them up for about £150 each. you can get aftermarket ballasts on ebay for about £40 but you will have to modify the headlight to fit it.
    #4
  6. stu_m
    Offline

    stu_m Well-Known Member VCDS Map User

    Joined:
    Oct 25, 2009
    Messages:
    1,442
    Likes Received:
    36
    [Apr 3, 2011]
    i had the same problem and it stopped after a couple of days use

    was told it could be the bulbs just needing time to bed in how true this is i dont know!!!
    #5
  7. BahnStormer77
    Offline

    BahnStormer77 BahnStormer

    Joined:
    Feb 4, 2009
    Messages:
    2,636
    Likes Received:
    18
    [Apr 4, 2011]
    I had similar (flickering and then going off)... but drivers side only... ballast needed replacing.
    #6
  8. QuottroA4
    Offline

    QuottroA4 Member

    Joined:
    Mar 4, 2009
    Messages:
    179
    Likes Received:
    3
    [Apr 4, 2011]
    Hmm, not the answer I wanted!

    Mine has D1S bulbs fitted so I'm guessing they will be very expensive. Is there any way I can test the ballasts before poddin out for new units?
    #7
  9. Woorlord
    Offline

    Woorlord shifting to Hyperspace... . VCDS Map User

    Joined:
    Dec 8, 2007
    Messages:
    949
    Likes Received:
    13
    [Apr 5, 2011]
    It would be a strange if both Ballasts were faulty at exactly the same time after replacing the bulbs, hence the question if both lights are flickering.
    If only one is flickering then I would swap the Ballasts from left to right and see if the fault moves - keep the bullbs and braided cable on the original side.
    This will let you then identify if it is a ballast/braid cable/bulb fault by elimination of items moved.

    If you need a new Valeo Ballast here is a source >>Link<<, this is very liklely cheaper than Audi and exactly the same part.
    #8
  10. BahnStormer77
    Offline

    BahnStormer77 BahnStormer

    Joined:
    Feb 4, 2009
    Messages:
    2,636
    Likes Received:
    18
    [Apr 5, 2011]
    yes!!!!! swap it with a working ballast: swap them over if one is working better on one side to the other.

    I didn't want to order the ballast (£300) and the bulb (£110) only to find that itwas a wiring/switching/sensor issue, so I took mine into Audi to check it since I figured it might need an Audi electrician: so probably only they would have all the spares and/or equipment to test it.... in the end they didn't have spare ballasts (even though I'd phoned in advance to check - servicing dept said they could see a stock confirmation and hold had been put on a bulb **doh!!**, but not on the ballast)... and the final test they did was to swap the ballasts over, so if you have one ballast working significantly better than the other, you might as well do that at home and save yourself the extra £125/hr labour. It was about £450-£500 in the end, £300-odd for the ballast, £125 for the labour + VAT.

    TBH: if it's ballast / bulbs broken, it's probably the same cost, unless you want yours running with two different colour bulbs: as Xenons age they fade from 4300K brilliant white through to various higher K blue shades with less light, so if you replace one, you may want to replace both anyway (two bulbs make up nearly the same cost of a ballast).
    #9
  11. QuottroA4
    Offline

    QuottroA4 Member

    Joined:
    Mar 4, 2009
    Messages:
    179
    Likes Received:
    3
    [Apr 5, 2011]
    Christ mate, what farse! Have identified that it is the nearside which keeps dropping out looking at the head light it appears to have some movement in it. Cant seem to get it to seat properly. Can't help but think if there has been constent movement it could of damaged the ballast?
    #10
  12. QuottroA4
    Offline

    QuottroA4 Member

    Joined:
    Mar 4, 2009
    Messages:
    179
    Likes Received:
    3
    [Apr 27, 2011]
    #11
  13. Woorlord
    Offline

    Woorlord shifting to Hyperspace... . VCDS Map User

    Joined:
    Dec 8, 2007
    Messages:
    949
    Likes Received:
    13
    [Apr 27, 2011]
    #12
  14. BahnStormer77
    Offline

    BahnStormer77 BahnStormer

    Joined:
    Feb 4, 2009
    Messages:
    2,636
    Likes Received:
    18
    [Apr 27, 2011]
    not sure if they're the same - I can't see those part numbers on VAGcat (although that means pretty much NOTHING!)...

    edit: here's the part on Vagcat (LINK): 8D0907391A
    Very strange as most B6 part numbers are "8E...", but that's what the vagcat says and the picture IS of a B6 headlight....
    Last edited: Apr 27, 2011
    #13
  15. QuottroA4
    Offline

    QuottroA4 Member

    Joined:
    Mar 4, 2009
    Messages:
    179
    Likes Received:
    3
    [Apr 27, 2011]
    Cheers for looking mate, just parniod of getting the wrong ones! As mine has D1S fitment bulbs opposed to the D2S ones also fitted to 02 plate cars! Gonna take the lamp units out tomorrow (weather dependent) to see if there are any loose connections as the flickering does seem to be vibration related.
    #14
  16. QuottroA4
    Offline

    QuottroA4 Member

    Joined:
    Mar 4, 2009
    Messages:
    179
    Likes Received:
    3
    [Apr 27, 2011]
    #15
  17. Woorlord
    Offline

    Woorlord shifting to Hyperspace... . VCDS Map User

    Joined:
    Dec 8, 2007
    Messages:
    949
    Likes Received:
    13
    [Apr 27, 2011]
    #16
  18. BahnStormer77
    Offline

    BahnStormer77 BahnStormer

    Joined:
    Feb 4, 2009
    Messages:
    2,636
    Likes Received:
    18
    [Apr 27, 2011]
    stick to woorlord's parts if they're a close OEM equivalent: £120 vs >£300!
    #17
  19. QuottroA4
    Offline

    QuottroA4 Member

    Joined:
    Mar 4, 2009
    Messages:
    179
    Likes Received:
    3
    [May 11, 2011]
    Update..

    Problem seems to of gone away!

    Doighnut here decided to leave his side lights on for over 28hrs which resulted in a flat battery and despite my best efforts (2 day trickle charge coupled by a 2 hr run) the old lead bestie kicked the bucket. So I needed another battery sharpish but only one problem, it was b/hol monday so I ended up podding out £102 for a Bosch silver top at Halfords(should of been 122 but had a voucher left over from crimbo) Annoying as there is a Bosch stockist local to me which stock them for £80!

    Anyways, that aside the flickering has disappeared which only leads me to beleive that it was a current issue? Think the OEM battery had seen too many winters, 9 of them to be exact. What did shock me was the spec of the OEM battery compaired to the Bosch S5 - 40Ah & 340 chranking amps compaired to 80ah and 740 pn the bosch! Maybe I have bought an over specced one? Nah, theres no such thing as over specced!!

    Thanks for all you advice tho chaps :icon_thumright::icon_thumright:
    #18
  20. QuottroA4
    Offline

    QuottroA4 Member

    Joined:
    Mar 4, 2009
    Messages:
    179
    Likes Received:
    3
    [May 22, 2011]
    Problem back again... :(
    #19
  21. Turkster
    Offline

    Turkster Bro.Paul 2.5TDI Quattro Sport

    Joined:
    Dec 11, 2007
    Messages:
    2,761
    Likes Received:
    34
    [May 22, 2011]
    here is an interesting side kick for you mate, I had this one too, it turned out that the starter motor live cable had rubbed against the other wire on the starter and was shorting out the system, so the car was getting a quick power drain and caused the lights to flicker,
    [​IMG]
    [​IMG]
    Last edited: May 22, 2011
    #20
  22. QuottroA4
    Offline

    QuottroA4 Member

    Joined:
    Mar 4, 2009
    Messages:
    179
    Likes Received:
    3
    [Mar 21, 2012]
    Does anyone have a 'how to' guide for removing ballasts?
    #21

Share This Page