1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hi guys, need a little help?????

Discussion in 'A3/S3 Forum (8L Chassis)' started by S3ren, Apr 16, 2008.

  1. S3ren

    S3ren Lovely Sunshine

    Joined:
    Dec 15, 2007
    Messages:
    172
    Likes Received:
    0
    Just put a new set of BBS LM reps on my S3 they came with a set of spigot rings on them but getting a vibration as you get faster, i had the balancing redone yesterday just to make sure it wasn't that.

    do you think that spigot rings aren't sitting on the hub properly?:uhm:
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. Nilz

    Nilz Defo worth the wait :)
    Audi Sport Owner Group Team Silver Audi S3

    Joined:
    Apr 9, 2006
    Messages:
    10,856
    Likes Received:
    649
    It could be the spigots, or it could be your nuts "oo er missus" just make sure they are the right size, as a mate has just had this prob as his were too small and caused alot of vibrations
     
  4. S3ren

    S3ren Lovely Sunshine

    Joined:
    Dec 15, 2007
    Messages:
    172
    Likes Received:
    0
    cheers bud never thought of that!!!!!
     
  5. Ibzzzzz

    Ibzzzzz Member

    Joined:
    Apr 22, 2007
    Messages:
    678
    Likes Received:
    3
    Hey dude get some pics up when ya can, do they look as good as shabz S3(from london, think its sold now though) or or s3_saf(he had a imola one also sold i think)?
     
  6. S3ren

    S3ren Lovely Sunshine

    Joined:
    Dec 15, 2007
    Messages:
    172
    Likes Received:
    0
    yer no probs bud i'm going to have that vibration looked at today then i'll clean it and post some pics tonight.............
     
  7. fingermouse

    fingermouse thats me

    Joined:
    Sep 6, 2004
    Messages:
    3,777
    Likes Received:
    16
    some places will balance the wheels on the car
     
  8. S3ren

    S3ren Lovely Sunshine

    Joined:
    Dec 15, 2007
    Messages:
    172
    Likes Received:
    0
    cheers for advise guys! had the wheels rebalanced today at another garage and where slightly out the guy also suggested that cause there new tyres they may need a little time to bed in roughly 500 miles, but it does feel alot better so finger crossed when i get my brother to go and give a blast so he can check it properly.
     

Share This Page