1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hi all, Just bought an A4 Avant TDi Quattro, gen on some issues

Discussion in 'A4/S4 forum(B5 Chassis)' started by evomaster3000, May 18, 2010.

  1. evomaster3000
    Offline

    evomaster3000 Member

    Joined:
    Dec 8, 2004
    Messages:
    449
    Likes Received:
    3
    [May 18, 2010]
    Hi all, My first post in the A4 B5 section as i've just bought this off ebay:

    [​IMG]

    http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=220604395339&ssPageName=STRK:MEWNX:IT

    I'm usually on the A6 C5 section having owned and built my 1998 A6 1.9TDi over the last 6 years.

    Anyway the A4 has a few issues, as far as i can tell the car is un modified, firstly the EGR is being deleted and the intake removed to be cleaned out as god knows what 180000 miles has done to it!

    Also I'm told the following issue need fixing:
    Front ABS sensor - seems simple enough tho never actually changed one
    Turbo overboost - Having had this on my A6 and cleaning and replacing the turbo both ov which didn't need cleaning the vanes, was the N75 so hopefully is the N75 as i don't fancy removing the turbo.
    Central locking not working - suspect pump, seen few on the bay, and a repair kit, it makes a noise but nothing happens

    I also think the gear selector rod is loose as i got it stuck in reverse the other day so will investigate this, having helped do a clutch on my A6 the setup is similar so will check that.

    Oh and the speedo and trip computer display is naffed, seems a common issue with the display, could this be linked to the speedo to?

    I've not had a chance to go over the car properly, but having had my A6 with the same engine, i know them quite well.

    Anyway anyone got any help for any of the issues, and any things to check atall that could save me time from experience would be much appreciated.

    Regards Jack
    #1
  2. Ads

    Ads

    [Nov 26, 2014]

  3. dieselfitter251
    Offline

    dieselfitter251 Blow ma own trumpet?

    Joined:
    Jun 3, 2007
    Messages:
    1,120
    Likes Received:
    0
    [May 25, 2010]
    Bloomin heck, I thought was going to be my old A4 tdi q avant for a moment there! On those issues, not much to offer other than on the front abs sensors. They 'should' be an easy enough fix but both mine were totally seized in. Ended up in splitting the hub and extracting them with much cursing and hitting. My Stinky went to 252k when I sold her, last I heard she'd miraculously lost 110k miles, so the B5's are obviously magic. ;O) Good luck.
    #2
  4. adamss24
    Offline

    adamss24 Well-Known Member

    Joined:
    Jul 3, 2007
    Messages:
    3,494
    Likes Received:
    192
    [May 30, 2010]
    I really hope its a front abs sensor and not the ABS pump ! Turbo overboost can be caused by a myriad of things, i would start by taking the turbo off for a clean-IF the rod does not appear to move freely ! Use a lenght of pipe to conect the actuator and suck on it till the rod hits the stop screw. If it goes nice and smooth then the turbo might be ok. Actuator failures are quite common on the v6 and they are not available separately so you need to look for 2nd hand ones ! CL pump will fail if there is a leak and the impeller will shatter. Check for leaks... Make shure the belts are new as they break without warning, aux. belt tensioner braket bush wears at about 150-170k so look for that as well and if you replace the belts make shure you fit a new watter pump and thermostat as they fail soon after ! If you're looking for a body-kit check my signature. I have a full Votex kit for sale (front spoiler,rear valance and 2x sideskirts) and also a deeper MS Design rear valance fitted to the stock rear bumper wich i am replacing with a facelifted s4 bumper so if you interested drop me a call on 077 899 12128. Thanks !
    Last edited: May 30, 2010
    #3

Share This Page