1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Helpppp agu not firing on 4th cylinder :(

smokiedee Jul 4, 2012

  1. smokiedee

    smokiedee Member

    118
    5
    18
    Hi i wonder if anyone has any ideas. I changed my fuel pump for one out of a low mileage golf and my car was running fine, even better than normal tgen drove it for about 25 mins then it started misfiring. I limped back home and swapped the fuel pump back over thinking it was that but didn't change a thing. I swapped the coil pack from 4 to 3 and then to 1 and still no joy. Also cleaned the injectors and changed the seals and filters and no change. Also just done the fuel filter with still no joy. Oddly though while driving uphill in i think it was 3rd gear it would vibrate a lot and heard a relay clicking and the dash lights flickers. Do you think a relay could be causing it not to fire on all 4?? Also my fuel pump relay is 167 not 409
     
  2. aragorn

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    17,774
    674
    113
    How do you know its cylinder 4?

    Typically its cylinder 2 that fails, and its due to the ignition module. For some reason the cyl 2 driver often seems to die first.
     
  3. smokiedee

    smokiedee Member

    118
    5
    18
    Wen i remove the plug for the injector on the 4th it stays the same where the others get worse. I think its the fuel pump relay so gonna try that first and hope it is especially as i heard a clicking sound behind the dash or is there an ecu relay also. Might be 1 out of the 2
     
  4. aragorn

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    17,774
    674
    113
    Its not the fuel pump relay if the rest of the cylinders are firing.

    I'd still suggest the ignition module is the most likely culprit.
     
  5. smokiedee

    smokiedee Member

    118
    5
    18
    Ok i'll see if i can get one to test it before i buy one
     

Share This Page