1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with minor misfire / hesitation ?

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Johnnyb, Jan 28, 2010.

  1. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 28, 2010]
    Hello

    Had my new 09 s3 for over a month now, done 3k miles, had it REVO'd and Forge DV fitted, now im quite sure i noticed this little problem before the mods but cant be too sure, anyway im experiencing some hesitation usually always whilst motorway driving, its a strange one as it happens when im keeping the revs and speed pretty still usually 3.5rpm in 6th gear (although it happens in 5th too), so im not on heavy load or even really accelerating at all, just keeping it moderate - then i get a very minor misfire, the only way i can describe it is if you imagine a short gust of wind hitting the front of the car - the car slows for a split second but the rev needle doesnt move (its def not wind lol, as ive been keeping an eye on it for a while), also it doesnt always happen can be every 5 mins or every 10 mins,

    Anyway, i took it down to Stattler today just to check there were no fault codes and there was none showing, everything seemed fine on the laptop, Steve suggested it could either be the DV stripping boost sometimes or just the nature of the software, either way not a big problem, which made me feel better.

    I then rang Mike at Votex who loaded the map, he suggested it could be the MAF sensor although he did point out this would be strange on such a new car, he said to put the car back to standard when the select switch comes and take it to the dealer to see what they say.

    To summarise, it is a very minor problem, but one of those things you constantly look out for as its always there, so quite irritating really.

    Any thoughts??

    Thanks
    Last edited: Jan 28, 2010
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. paddy
    Offline

    paddy Audi=No fault code, no idea

    Joined:
    Feb 6, 2008
    Messages:
    5,133
    Likes Received:
    123
    [Jan 28, 2010]
    If it was a 3.2 i would say sell it quick....
    #2
  4. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 28, 2010]
    Its something certain people could live with, but im a bit of a perfectionist so i need to get it checked, i just wonder why when i floor it its fine right til 6500, then when driving sensibly it happens now and again
    #3
  5. Phil_T
    Offline

    Phil_T Revo Stage 2+ Audi S3

    Joined:
    Oct 19, 2009
    Messages:
    242
    Likes Received:
    4
    [Jan 28, 2010]
    Think it does it on mine, sure it did it on my mates too & from lots of reading its down to the downpipe that you need to uprate to a miltek etc. Sure someone will come along & back me up on this
    #4
  6. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 28, 2010]
    Thats good to know (in a nice way of course), ive had proper misfires on cars before when needing new plug and coils packs and its nothing like that, does yours feel like wind is hitting against it just for a split second? The downpipe is a credible point but whats making me think it cant be that is the fact that it happens when under light load, i can red line the car in every gear and its smooth all the way through, but plodding along the motorway doing an average speed it occurs now and again.

    Something else i think it could be is that whenever it happens, its just on slightly on boost and at a certain rev point (revs drops slightly) it loses it as normal and causes it to dip, and the other way round......from what my REVO dealer said, you dont need any hardware for stage 1, although it complements the software
    #5
  7. S.
    Online

    S. Well-Known Member

    Joined:
    Mar 5, 2009
    Messages:
    1,442
    Likes Received:
    217
    [Jan 29, 2010]
    you don't need hardware, but on new s3's i think there are some problems with downpipe etc.
    #6
  8. GConn
    Offline

    GConn Member

    Joined:
    Jan 13, 2009
    Messages:
    236
    Likes Received:
    0
    [Jan 29, 2010]
    The missfires that S. and Phil_T mention happen at high revs and only to S3s produced during a certain period. This is a different issue IMO. Anything that isn't normal needs to be fixed. I would definitely try and solve the problem, just for the peace of mind.
    #7
  9. S3Alex
    Online

    S3Alex Rarely neutral

    Joined:
    Dec 3, 2008
    Messages:
    5,783
    Likes Received:
    1,271
    [Jan 29, 2010]
    If you've not had the exhaust done,I would look at that as a possible problem.

    I think that the software is developed around a specific hardware package,i.e.for Stage 2,exhaust and CAI/DV....for Stage 2+,all of these plus the HPFP etc.
    When you deviate from that,you may expect a few hiccups,as I did by trying to keep the car looking reasonably stock under the bonnet and not fitting a CAI.

    Then the misfire began...it did get traced back to the intake after some discussions with AMD and Revo,both of whom were extremely helpful,but it highlights my point about the package as a whole.
    #8
  10. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 29, 2010]

    Well Steve at stattler did mention an air intake may smooth it out, i was thinking of getting one anyway in february. After a lot of thinking last night i can definitely say that this little hesitation was there before the mods as i had the DV and map done within 2 days of each other and remember feeling the hesitation further back than that.

    So i think the best thing to do is to take the map off when the switch arrives and double check its still doing it, if it is then i will take it to Audi but i just cant put my finger on what it could be? there are no fault codes showing, the car runs smoothly around town etc and is smooth in every gear on full load.......maybe it is just the wind!!!

    Will keep you updated
    #9
  11. S3Alex
    Online

    S3Alex Rarely neutral

    Joined:
    Dec 3, 2008
    Messages:
    5,783
    Likes Received:
    1,271
    [Jan 29, 2010]
    If you've not had the intake or exhaust done,then I'd certainly say that's your problem.

    To run anything beyond Stage1 you really should be getting these done,as the stock exhaust is more restrictive than the Miltek,and the stock CAI definitely limits gas flow at high rpm.

    Mine was occurring regularly at 6500rpm,causing persistent misfires,which were not cleared by increasing fuelling(so it wasn't the mixture leaning out)and cleared instantly(!) by changing to a Forge CAI.
    #10
  12. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 29, 2010]
    So did you have the problems at stage 1 or 2 before u added the hardware ? I'm gonna stick at stage 1 and have always planned the CAI later on, I didn't think that the DP would be essential at stage 1, also do you definitely think it could be the CAI or DP even though the hesitation appears at moderate motorway speed whilst feathering the accelerator ? I can plant it in any gear and have no problems even at 6500rpm, surely on heavy load the air intake and downpipe would be working harder thus giving them more chance to misfire

    Thanks
    #11
  13. S3Alex
    Online

    S3Alex Rarely neutral

    Joined:
    Dec 3, 2008
    Messages:
    5,783
    Likes Received:
    1,271
  14. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 29, 2010]
    So i guess you knew what yours was straight away as you went to stage 2 without the required hardware, mine is a different situation, i think it has always been there since i got the car from new, but the software may have highlighted it more, im hoping to get my select switch by at least monday so will revert it back to standard and report back.

    Im thinking of gettin the new pipercross venom next month, but im struggling to source a decent looking and adequate fitting engine cover as im not a fan of the exposed engine, hopefully this will make a few nice improvements as im told the OEM filter its very restrictive.
    #13
  15. S3Alex
    Online

    S3Alex Rarely neutral

    Joined:
    Dec 3, 2008
    Messages:
    5,783
    Likes Received:
    1,271
    [Jan 29, 2010]
    In a sense.....the misfire was evident from when the Stage2 software went on,but made much more obvious when I had the HPFP fitted and loaded that Stage2+ software,and we couldn't get it to run up to or beyond 6500rpm.
    Both myself and AMD had felt that the stock system was probably better than it actually was,and in the end it was this that we tracked the fault down to.

    The OEM filter is restrictive,and the aftermarket filter inserts for the stock system such as the Pipercross filter do open it up a bit,but are no substitute for proper higher slow systems such as the Forge,Evoms,Venom etc etc.
    #14
  16. Phil_T
    Offline

    Phil_T Revo Stage 2+ Audi S3

    Joined:
    Oct 19, 2009
    Messages:
    242
    Likes Received:
    4
    [Jan 29, 2010]
    Like I said above mine does this since its been mapped & mine has Evoms & Forge DV, My mates with the same mods but on a 58 plate dig the same until he went to stage 2+. The best way to describe is it like a slight hesitation/wind blown the car. I dont think its anything to worry about but I know it wasnt there before the remap even when it was standard & also when it just had them Evoms intake on its own but I think its the downpipe tbh from reading up alot over various threads
    #15
  17. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 29, 2010]
    Cool, must be that then, i think its the car momentarily losing boost for a split second then coming back on, obviously yours sounds the same as mine but does yours do it whilst hovering around a certain rpm i.e 3.5k or does yours do it when you plant your foot?

    The difference is that im almost certain that it was there on mine before the mods, but as you say its not a serious problem - i have no engine lights coming on and no faults showing on VAG.COM , are you considering the DP soon then?
    #16
  18. Phil_T
    Offline

    Phil_T Revo Stage 2+ Audi S3

    Joined:
    Oct 19, 2009
    Messages:
    242
    Likes Received:
    4
    [Jan 29, 2010]
    Yes mate its around them sort of revs, never when I open it up & like you said its just when crusing
    #17
  19. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 30, 2010]
    Well I rang REVO (excellent customer service) to try get to the bottom of it, the conclusion was what I thought - they said the only thing they can put it down to was that its just momentarily losing or gaining boost at that rev range as they said 3.5k in 6th gear is right on the cusp of boost, also they said it will be more sensitive cos of the forge DV as it obviously is trying to spool up earlier and holding boost longer, this makes sense as it only occurs when I'm at that rev point, driving the car a bit harder is absolutely fine as your not coming on and off the accelerator.

    So I definitely feel better, they said the CAI may help smooth it out but said its more worthwhile cos the OEM is so s**t , I also got my select plus switch this morning (nice bit of kit) so will switch back to standard after the wkend and see how it feels.

    So Phil I don't think its anything to worry about, our cars are just far more sensitive now so have to expect little changes from the engine, its something I'm sure I can live with as its fairly minor
    #18
  20. dc240969
    Offline

    dc240969 Member

    Joined:
    Oct 12, 2008
    Messages:
    887
    Likes Received:
    0
    [Jan 30, 2010]
    Could this be the down pipe issue? Mine went when l got a turbo back exhaust.
    #19
  21. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 31, 2010]
    It could be, but REVO have said the stage 1 software is developed for no additional hardware, because of the nature of the hesitation i cant see why a DP would make stop it, would it not make it even more sensitive?

    If i were to go down the DP route i think i would go with JamieKips setup, as he has managed to keep his stock pipes, but for now the first thing on the list is the CAI

    Thanks
    #20
  22. dc240969
    Offline

    dc240969 Member

    Joined:
    Oct 12, 2008
    Messages:
    887
    Likes Received:
    0
    [Jan 31, 2010]
    lve got a thread on here, or vagoc, that follows my trials and tribulations. my misfire didnt go away until l went full tbe.
    #21
  23. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 31, 2010]
    How bad was your misfire? did it happen all the time? ideally i would like a TBE, but gonna have to save up for it, the misfire is something i can live with for now as i know whats causing it, its not something thats gonna harm the car, but TBE and CAI will hopefully be fitted in the next few months
    #22
  24. dc240969
    Offline

    dc240969 Member

    Joined:
    Oct 12, 2008
    Messages:
    887
    Likes Received:
    0
    [Jan 31, 2010]
    Mines only appeared in high revs, 5500, now and then, maybe 3-4 times. l had my coilovers and ecu changed, l put iridium plugs in but nothing made any difference. l put my forge cai in and the misfire moved higher up the range, not where it would affect you on the daily drive. Had my tbe in since september and seen nothing since, except a fuelling problem but that was a dodgey map. Having some clutch slippage at the moment so lm running in standard map until lve got some readies for a new clutch.
    #23
  25. V6Pete
    Offline

    V6Pete Now running on Bentley's y'all

    Joined:
    Feb 15, 2009
    Messages:
    1,491
    Likes Received:
    2
    [Jan 31, 2010]
    And changing your coilovers didn't sort your misfiring? That would have been the first thing I'd have thought ;)
    #24
  26. dc240969
    Offline

    dc240969 Member

    Joined:
    Oct 12, 2008
    Messages:
    887
    Likes Received:
    0
    [Jan 31, 2010]
    yeah, l was working on two things at once when l wrote that, packs l meant, of course you knew that.
    #25
  27. V6Pete
    Offline

    V6Pete Now running on Bentley's y'all

    Joined:
    Feb 15, 2009
    Messages:
    1,491
    Likes Received:
    2
    [Jan 31, 2010]
    I did know that. But I figured somebody would point it out, so hey, why not me?
    #26
  28. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 31, 2010]
    Seems like you had a bit of a nightmare, glad the TBE sorted it out, it seems that your misfire is the opposite of mine though, i seriously wouldnt even take an Audi tech out in it to show them as i know it probably wouldnt happen for about 10 mins and when it does its very hard to notice as its so quick, but its def there im not imagining it. Im probably contradicting myself here but it may have started after the DV was fitted, it would make sense as the mod is centred around boost and spooling up improvements.

    How did the car feel performance wise after the TBE was fitted?
    #27
  29. Spin140
    Offline

    Spin140 Active Member

    Joined:
    Mar 2, 2005
    Messages:
    2,014
    Likes Received:
    28
    [Jan 31, 2010]
    Why did you bother fitting the DV anyway Jonny ? I may be wrong but it was my understanding that these are no longer required on the newer S3's and as you are not after any additional noise it seems a good idea to take it off and stick it on flea bay or in the calssifieds.

    I think if stealth is your requirement then an intake is out of the question but I wouldn't worry, if you can afford it fit the full exhaust (resonated) and an intake and enjoy the full potential, it's true that several people have posted about the odd issue but they do seem to be in the minority, my previous S3 went in for a service and warranty work related to brakes and wheel bearings and nothing was mentioned about my intake or exhaust.

    My previous S3 ran faultlessley on both GIAC extreme and Revo Stage 2 + with no issues in 10,500 miles including 6 track days.

    I have all the hradware on mine at the minute and have just covered the first 1,000 miles so just need to decide on which remap this time around, looking forward to acually revving this one to a level where it might mis-fire.

    Hope you get it sorted and keep us posted.
    #28
  30. dc240969
    Offline

    dc240969 Member

    Joined:
    Oct 12, 2008
    Messages:
    887
    Likes Received:
    0
    [Jan 31, 2010]
    Sweet as a nut. You not getting any errors? l would go for the new oem dv unit if you think it may be dv related. l was going to do a forge dv but read that the new oem unit is just as good. reading back this thread that would be what l would be doing.
    #29
  31. dc240969
    Offline

    dc240969 Member

    Joined:
    Oct 12, 2008
    Messages:
    887
    Likes Received:
    0
    [Jan 31, 2010]
    Didnt work well with my 3.
    #30
  32. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 31, 2010]
    Cheers fellas

    Spin - I should have really done more research into the newer S3's DV, i just followed my old path of mods from my last older S3, you may be right that i should take it off, i have actually just inspected the OEM DV and the quality does seem much better than my 07 models. I think i read somewhere before i got the car that the OEM unit will eventually pack in, also reading most peoples sigs it alays seems to pop up along with the usual suspect mods. One thing Steve jnr at Stattler did say was to stick the OEM DV back on and see how it feels, might be worth a try.

    With regards to the intake, i dont mind a bit of extra noise and navnayyar has just informed me that the new pipercross CAI only produces a little more noise than the standard intake, so this is the front runner at the moment. I actually rang Audi the other day to be up front with them regarding the intake / warranty issue, they said that its fine but if something goes wrong which they can link to air flow then the warranty would be void - fair enough i suppose.

    Spin are you toying with REVO and GIAC for the remap option then? Steve says even the new stage 1 GIAC software has improved alot since i had mine done...oh and he said your car looks lovely!
    #31
  33. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 31, 2010]
    Something i have just noticed !

    I was looking in the forge DV box that it came in and found a spring in little plastic bag, there is a sticker on the plastic saying "please keep this spring / code FMSS114-yellow) This spring may be needed if you have your ECU re-mapped"

    Any thoughts? would this solve the problem?
    #32
  34. Spin140
    Offline

    Spin140 Active Member

    Joined:
    Mar 2, 2005
    Messages:
    2,014
    Likes Received:
    28
    [Jan 31, 2010]
    Still undecided which map to go for, the Revo stage 2+ certainly produced the goods on an accurate Dyno of 343bhp and felt really strong high up the rev range but for road driving I can't say there was a massive difference to be felt unless you have unlimited roads to play on. I was happy with both offerings of software but got caught up in the dyno lottery. Any software that can produce a reliable 340 bhp on a dyno dynamics RR will get due consideration as I'm still convinced this is the actual power we are making on stage 2 + level, I know many of us are quoting 370 but it's very dyno specific from what I've read, much better in my opinion to have a trouble free reliable map and lets be honest 340+ bhp from our humble 2.0 T is pretty amazing.


    I'm itching to get it mapped but this time around but as I know exactly what to expect so am considering all options.

    I'll post a review and some dyno results once its done.

    TBH Jonny if you never plan to use the car on track I'd probably stick with your original plan and just stay at stage 1 ,protecting your anonomity when visiting dealers etc and yet still being a very capable and fast car, but having said that it's a bit infectious especially if you keep coming on here !! :)
    #33
  35. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 31, 2010]

    Too right! its a slippery slope this modding lark, ASN is the devil.....but in all honesty i really enjoy it, its the anticipation of "how will it feel" after i put a CAI on or TBE etc...

    For my next and probably final move i think im gonna go down the CAI route get the engine cover cut to fit and leave it at that, then try out some "Audi-sport.net patches on my arm" to curb any more abuse on my wallet, knowing me i will be sat here in a months time reviewing my stage 2+ setup.

    I think your right about the Dyno situation, its something thats never really bothered me too much and more so since reading the conflicting results on here, to me if the car feels quick as it does now then im happy with that, i think i would be too worried that id be disappointed with the result.
    #34
  36. Spin140
    Offline

    Spin140 Active Member

    Joined:
    Mar 2, 2005
    Messages:
    2,014
    Likes Received:
    28
    [Jan 31, 2010]
    Put me down for a packet of the ASN patches :)
    #35
  37. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 31, 2010]
    I think its too late for you Spin, i will try save the others....
    #36
  38. dc240969
    Offline

    dc240969 Member

    Joined:
    Oct 12, 2008
    Messages:
    887
    Likes Received:
    0
    [Jan 31, 2010]
    your having a laugh arent you?
    #37
  39. Johnnyb
    Offline

    Johnnyb Member

    Joined:
    Jul 10, 2007
    Messages:
    730
    Likes Received:
    296
    [Jan 31, 2010]
    No mate....why?

    I did a google search on it, couldnt find much but read a few things about the yellow spring being needed for more PSI, it would seem that its not needed unless your running a big PSI, i could be wrong - in fact i know im probably wrong but any light shed on this would be greatly appreciated
    #38
  40. tku
    Offline

    tku Member

    Joined:
    Sep 29, 2009
    Messages:
    631
    Likes Received:
    1
    [Jan 31, 2010]
    Dude, what's going on with car man? Your having a few issues already.
    #39
  41. tku
    Offline

    tku Member

    Joined:
    Sep 29, 2009
    Messages:
    631
    Likes Received:
    1
    [Jan 31, 2010]
    And where is this milltek group buy?!! :) I need one.
    #40

Share This Page