1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with car problem

Discussion in 'General Chat' started by macpdm, Oct 20, 2012.

  1. macpdm
    Offline

    macpdm Member

    Joined:
    Jul 21, 2011
    Messages:
    410
    Likes Received:
    3
    [Oct 20, 2012]
    Hi guys

    I have noticed that my wifes Fiesta when hot gives of a smell like hot radiator water. I noted water under the car and at the back of the engine bay. I also noted the water in the reservoir has dropped. I thought it was HGF but the oil seems ok no evidence of water in the oil and the temp guage remains bang in the middle where it usually is. The radiator seems dry and the water is coming from the back somewhere but the engine block seems dry too. Any ideas ??
    Last edited: Oct 20, 2012
    #1
  2. Ads

    Ads

    [Sep 20, 2014]

  3. sidibear
    Offline

    sidibear Looking for Zombies !! Staff Member Moderator

    Joined:
    Nov 5, 2008
    Messages:
    2,056
    Likes Received:
    442
    [Oct 22, 2012]
    Heater Matrix is my guess.
    #2
  4. macpdm
    Offline

    macpdm Member

    Joined:
    Jul 21, 2011
    Messages:
    410
    Likes Received:
    3
    [Oct 22, 2012]
    Yes I had not thought about the matrix but there is no water on the carpets ?
    #3
  5. lanceneoman
    Offline

    lanceneoman A4 S-Line 1.8T Avant 230 BHP

    Joined:
    Oct 21, 2012
    Messages:
    38
    Likes Received:
    0
    [Oct 22, 2012]
    air con? try putting some rad weld in and see if it stops otherwise a possible split pipe i guess
    #4
  6. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,806
    Likes Received:
    500
    [Oct 22, 2012]
    ill go for the matrix aswell
    reason cos of the smell you get.
    #5
  7. macpdm
    Offline

    macpdm Member

    Joined:
    Jul 21, 2011
    Messages:
    410
    Likes Received:
    3
    [Oct 22, 2012]
    The car has no aircon though guys ?

    Im thinking its a split pipe somewhere, I hope.
    #6

Share This Page