1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help PROBLEMS Juddering 2.0 TDi 170

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by jspeed2, Sep 11, 2012.

  1. jspeed2
    Offline

    jspeed2 New Member

    Joined:
    Jun 14, 2012
    Messages:
    7
    Likes Received:
    0
    [Sep 11, 2012]
    Hello there I have an audi a4 avant 2.0TDi 170 and I am having a few problems

    I have read hundreds of threads on the internet about 170s and problems and I hope you can help me with my latest one.

    The problem is the car will not accelerate when put foot down in all gears the car just judders like mad and takes ages to drive, this happens in all gears but will accelerate v slowly if just hold foot at about quarter throttle.

    If I am above 2000 revs in all gears then put foot down hard the car wont judder but just feels like is not boosting and accelerates like a non turbo.

    This only happens when car is warm if car is cold for first couple mins only of the drive, the car will fly like a 170 should but goes straight back to the symptoms after about 3 mins driving.

    The car has had
    new turbo - last year
    new egr - last year
    new DMF
    Injectors x2
    vacuum unit on inlet
    cleaned egr numerous times
    couple fuel filters - with no signs of oil in the filter
    checked Vac pipe lines

    The car has been in garage all week for latest set of injectors which i will be beginning my fight with Audi uk tomorrow to get money back, and the garage don't have a clue for the problem. On VCDS (VagCom) it shows up nothing all values on measuring blocks are correct even when driven and there are no fault codes so I have no idea what is going on please can you help ?

    Many Thanks

    Jason
    #1
  2. Ads

    Ads

    [Sep 20, 2014]

  3. eddscott
    Offline

    eddscott Member

    Joined:
    Feb 6, 2012
    Messages:
    164
    Likes Received:
    7
    [Sep 13, 2012]
    My 170 is doing something very similar.

    Cold it isn't as noticeable but I believe it still does it. Once warm its juddering most noticeably in the lower gears. Part throttle its fine but foot down - judder. Its also intermittant as to how bad it is. Sometimes its a just a little stutter when flooring it other times the whole car shakes.

    According to Audi they replaced all the injectors and the loom on mine in March. I've had the DPF, EGR and EGR cooler removed.

    Booked into a local indy for Monday to see what the score is.
    #2
  4. warren_S5
    Offline

    warren_S5 Moderator Staff Member Moderator VCDS Map User

    Joined:
    Oct 31, 2007
    Messages:
    7,176
    Likes Received:
    2,358
    [Sep 13, 2012]
    My borther in laws 170 TDi A3 has just been into Stratford Audi for an injector loom replacement but it's still juddering at low speeds. We tried an extended run at high revs to try and clear DPF, but it doesn't seem to make much difference. Someone suggested checking the throttle body (clean up), but sounds like a PITA. He's run injector clean up and has literally given up knowing where to go next. Shame as it ruins the ownership experience on a car that's literally just tripped out of the warranty period.
    #3
  5. jspeed2
    Offline

    jspeed2 New Member

    Joined:
    Jun 14, 2012
    Messages:
    7
    Likes Received:
    0
    [Sep 16, 2012]
    Thankyou for your replys :)

    I would be interested to hear your out come of the indy garage if possible hopefully its good news for you.

    Your right it really does ruin the experience of owning an audi tempted just to get it fully sorted and sell on quick before next 'well known' problem goes :-(.

    Mine has cut out fully again and towed to audi again so hopefully they can have another go at fixing it will keep all updated.
    #4
  6. eddscott
    Offline

    eddscott Member

    Joined:
    Feb 6, 2012
    Messages:
    164
    Likes Received:
    7
  7. nickjw2000
    Offline

    nickjw2000 New Member

    Joined:
    Sep 4, 2012
    Messages:
    24
    Likes Received:
    0
    [Sep 30, 2012]
    I had the same problem with my A3 TDI 170. All four injectors and the loom were replaced 6 months ago.

    No drama though, as Eddscott suggested, I spent £15 on a new fuel filter and it's made the world of difference. Simple 10 minute (but messy) job.

    Definitely worth a shot.
    #6
  8. Scottyt
    Offline

    Scottyt New Member

    Joined:
    Jan 12, 2013
    Messages:
    12
    Likes Received:
    0
    [Jan 13, 2013]
    My a3 2.0 tdi is juddering too usually in 1 and 2 gears the revs go up and down abit almost like its holding back then all of a sudden it rites itself and away it goes its a dsg by the way but had gear box tested no faults, have changed the fuel filter its a little better any ideas on where to go next?
    #7
  9. damo211174
    Offline

    damo211174 New Member

    Joined:
    Jan 14, 2013
    Messages:
    1
    Likes Received:
    0
    [Jan 14, 2013]
    it sounds to me like a flywheel problem mate
    #8
  10. Scottyt
    Offline

    Scottyt New Member

    Joined:
    Jan 12, 2013
    Messages:
    12
    Likes Received:
    0
    [Jan 14, 2013]
    Shouldnt be the flywheel because had new one fitted about a thousand miles ago along with clutch and oil pump and oil cooler?
    #9
  11. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Jan 14, 2013]
    I'd say fuel filter as well buddy.
    #10
  12. Purdy99
    Offline

    Purdy99 Member

    Joined:
    Nov 6, 2012
    Messages:
    90
    Likes Received:
    4
    [Jan 17, 2013]
    hey guys, just posted this in a lumpy idle thread, but this can also help with driveabilty as it did with mine, cheap and easy to do, just click the link and look what i posted, http://www.audi-sport.net/vb/audi-s4-a4-a4-cab-b7-chassis/177633-audi-a4-tdi-170-lumpy-idle.html
    regarding the EGR valve gasket mod,

    also tho i had a very nasty judder in mine, when you put the foot down, turned out it was the torque limiter cutting in, however i notice this is quite an old thread so you may of all sorted out the problems i hope,
    #11

Share This Page