1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP PLZ 2.4 v6 irratic idle / misfire

Discussion in 'A4/S4 forum(B5 Chassis)' started by cammy43, Nov 8, 2011.

  1. cammy43
    Offline

    cammy43 New Member

    Joined:
    Nov 8, 2011
    Messages:
    5
    Likes Received:
    0
    [Nov 8, 2011]
    hi guys, getting hairless now with this. have a problem with my v6. Had apparent misfire when idling and acccelerating. Scaned for faults but none showed up. Replaced coil pack , plugs and leads. no change. Just replaced coolant sensor yesterday and the problem seems worse, idle is going up and down from 100 to 600. Checked all my vaccum pipes and all are ok. The car judders when accelerating in high gear occasionally hear a popping noise from the engine like an internal misfire. Exhaust seems pretty smelly as well. was going to replace my throttle body but thought id just ask on the forum first. Any thoughts plz. Desperate here. aLSO CAN FEEL THE ACCELERATOR PEDAL TWITCHING ON ITS OWN.
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. towcestervag
    Offline

    towcestervag Member VCDS Map User

    Joined:
    Jan 14, 2011
    Messages:
    165
    Likes Received:
    5
    [Nov 8, 2011]
    i would try cleaning and resetting throttle body first
    #2
  4. cammy43
    Offline

    cammy43 New Member

    Joined:
    Nov 8, 2011
    Messages:
    5
    Likes Received:
    0
    [Nov 8, 2011]
    i have cleaned it but how do you reset the throttle body. thx
    #3
  5. gen.heinz guderian
    Offline

    gen.heinz guderian Well-Known Member Regional Rep VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,359
    Likes Received:
    125
    [Nov 9, 2011]
    you need VCDS to perform throttle body adaptation.
    Have you checked MAF sensor?
    #4

Share This Page