1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help please!??

Discussion in 'A3/S3 Forum (8L Chassis)' started by Beany113, Aug 24, 2013.

  1. Beany113

    Beany113 Member

    Joined:
    Aug 21, 2013
    Messages:
    50
    Likes Received:
    0
    Hi all, probably the wrong part of the forum but need a quick answer! Just on my way home in the s3
    ive just bought and the oil light has come on!! I'm at the garage and nearly bought helix 5w40 but want too sure on it being correct please some tell me ASAP thankyou!!
     
  2. Advert Guest Advertisement


  3. Sandra

    Sandra MODERATOR
    Staff Member Administrator Moderator TeamMisano TFSI Owners Group Gold Supporter quattro Audi S3 s tronic

    Joined:
    Sep 12, 2010
    Messages:
    23,983
    Likes Received:
    7,092
    What year is your S3? I have moved this into a3 8l.
     
  4. gen.heinz guderian

    gen.heinz guderian Well-Known Member
    VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,346
    Likes Received:
    125
    Have you checked the oil level?
     
  5. Beany113

    Beany113 Member

    Joined:
    Aug 21, 2013
    Messages:
    50
    Likes Received:
    0
    S3 is a 2001 plate
     
  6. Beany113

    Beany113 Member

    Joined:
    Aug 21, 2013
    Messages:
    50
    Likes Received:
    0
    Just checked oil level on a reasonably flat ground and looks ok, the oil light came on the dash so I panicked and pulled in services ASAP
     
  7. <tuffty/>

    <tuffty/> Badger 5 Edition...Its all about the flow...
    Staff Member Moderator Audi S3

    Joined:
    Sep 14, 2008
    Messages:
    19,963
    Likes Received:
    3,290
    Specs suggest it meets VW requirements so yeah will be fine...

    <tuffty/>
     
  8. Beany113

    Beany113 Member

    Joined:
    Aug 21, 2013
    Messages:
    50
    Likes Received:
    0
    Thanks tuffy!! The oil seems to be okay now? The oil light hasn't come on, on the dash and te oil level is half on the stick.. Kinda puzzled now as this is my first audi and I've drive it 25 miles lol
     
  9. Westy

    Westy Well-Known Member

    Joined:
    Dec 2, 2008
    Messages:
    17,445
    Likes Received:
    1,087
    Definitely wasn't the oil pressure light was it!!!!
     
  10. Beany113

    Beany113 Member

    Joined:
    Aug 21, 2013
    Messages:
    50
    Likes Received:
    0
    On my dash the oil sign came up mate so just presumed that it was low on oil? :/
     
  11. Beany113

    Beany113 Member

    Joined:
    Aug 21, 2013
    Messages:
    50
    Likes Received:
    0
    It could have been the oil pressure light! But when I turn ignition on its no longer there! What shall I do people?
     
  12. Beany113

    Beany113 Member

    Joined:
    Aug 21, 2013
    Messages:
    50
    Likes Received:
    0
    Now when I turn the ignition on the dash comes up with okay, can anyone please advise me on what to do? Thankyou
     
  13. Westy

    Westy Well-Known Member

    Joined:
    Dec 2, 2008
    Messages:
    17,445
    Likes Received:
    1,087
    Can you remember what colour the sign was? Take a look in the manual. I'm sure yellow is oil level and red is pressure.
     
  14. Beany113

    Beany113 Member

    Joined:
    Aug 21, 2013
    Messages:
    50
    Likes Received:
    0
    Yeah I'm pretty sure it was red mate. It's gone now though and I've had car in tick over for 5 mins and its fine now?
     
  15. Beany113

    Beany113 Member

    Joined:
    Aug 21, 2013
    Messages:
    50
    Likes Received:
    0
    Right it the low oil warning light but I've checked my oil and its fine. Why is the light coming? Oil sensor playing up? Thanks guys
     
  16. vivalacoulter

    vivalacoulter Active Member
    VCDS Map User Gold Supporter Audi S5

    Joined:
    May 25, 2013
    Messages:
    370
    Likes Received:
    47
    Looks like it's the sensor then mate :) lucky really!
     
  17. Beany113

    Beany113 Member

    Joined:
    Aug 21, 2013
    Messages:
    50
    Likes Received:
    0
    Yeah I hope so mate just gotta try and locate the sensor and swap it over today!
     
  18. Beany113

    Beany113 Member

    Joined:
    Aug 21, 2013
    Messages:
    50
    Likes Received:
    0
    Right I've looked at the problem and it seems to be reasonably common? When I get my lazy arse out of bed ill check to see if the oil sensor connections are okay and it hasn't become unplugged. Then the next stage is buying an OEM sensor for £60 from audi and do an oil and filter change... Niiice little bill after just buying a car -.- lol.
     
    #17 Beany113, Aug 25, 2013
    Last edited: Aug 25, 2013

Share This Page