1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help Please 2.0T FSI Rattle

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by heli_madken, Aug 18, 2010.

  1. heli_madken
    Offline

    heli_madken Member

    Joined:
    Mar 26, 2008
    Messages:
    117
    Likes Received:
    0
    [Aug 18, 2010]
    I have just taken delivery of a 2.0T FSI S-Line SE Avant 06 plate 52K mileage FSH from a dealership, when I got home the engine sounds like its full of nails with a pronounced rattle coming from the housing at the rear of the cylinder head, used the screwdriver to ear trick to locate it

    Going back with it tomorrow but could anyone tell me what the housing is as I am not familiar with this engine looks like it could be the water pump. Sounds like some form of tensioner problem are there any known problems from this area with this engine

    Any help would be appreciated
    #1
  2. Ads

    Ads

    [Sep 22, 2014]

  3. heli_madken
    Offline

    heli_madken Member

    Joined:
    Mar 26, 2008
    Messages:
    117
    Likes Received:
    0
    [Aug 19, 2010]
    Just spoken to the workshop technician, he is claiming that these engines are noisy due to the high pressure injection system, is this true? do these engines really sound like a diesel at tickover, can any owners confirm this.

    The noise is coming from what turns out to be the injector pump housing I am convinced that the tensioner is slack as I can hear the chain thrashing but a scan shows no faults so thay are claiming the tensioner is ok

    Please help as I dont want to be fobbed off
    Last edited: Aug 19, 2010
    #2
  4. stevehall
    Offline

    stevehall Member VCDS Map User

    Joined:
    Aug 26, 2008
    Messages:
    300
    Likes Received:
    0
    [Aug 19, 2010]
    my is loud, and it was the day i got it (2 years ago and 60k miles) and it still sounds the same.
    #3
  5. rs_t
    Offline

    rs_t New Member

    Joined:
    Apr 6, 2007
    Messages:
    18
    Likes Received:
    0
    [Aug 19, 2010]
    Its true. Mine and everyother I've heard is the same.
    #4
  6. goon
    Offline

    goon Member

    Joined:
    Jul 31, 2006
    Messages:
    323
    Likes Received:
    1
    [Aug 19, 2010]
    its true at tickover these do sound tappety,when I bought mine there were 2 others there,started them up and all 3 were the same.
    #5
  7. hazey7
    Offline

    hazey7 Member

    Joined:
    Sep 2, 2009
    Messages:
    170
    Likes Received:
    1
    [Aug 20, 2010]
    Yes, concur, although my 2.0T sounds OK at tickover, acceleration within the car especially in first gear sounds almost like a diesel. There's lots of previous discussion on this subject throughout the A4 B7 forum.... its the direct injection system which is the same as a diesel's injector system.....
    #6
  8. heli_madken
    Offline

    heli_madken Member

    Joined:
    Mar 26, 2008
    Messages:
    117
    Likes Received:
    0
    [Aug 20, 2010]
    Hi Thanks everyone and apologies I should have done a search just panicking in the timescale I had

    Just got back from the dealers and they have finally agreed with me that there is a noise coming from the fuel pump housing, they have ordered a few parts and the car is going back in on the 6th to be done. Reading around there is a common wear problem with the follower so its probably going to be this.

    Thanks again, I iwll let you know how I get on
    #7
  9. Johnytuono
    Offline

    Johnytuono Member

    Joined:
    Jun 19, 2007
    Messages:
    132
    Likes Received:
    0
    [Aug 20, 2010]
    .....thats one of the things I hate about getting a 'new' car....finding out about all the little niggles/marks, different sounds etc......
    JohnyT
    #8
  10. MurdoD
    Offline

    MurdoD New Member

    Joined:
    Sep 1, 2010
    Messages:
    6
    Likes Received:
    0
    [Sep 1, 2010]
    heli_madken, i'd appreciate knowing how you get on once you get your car back with the new parts...

    My 2.0T FSI also sounds ropey (and yes, i've asked the question before, and yes, i've had much the same answers...) but non the less.. if this helps yours I may investigate my own further!
    #9
  11. snoopy
    Offline

    snoopy New Member

    Joined:
    Sep 4, 2010
    Messages:
    28
    Likes Received:
    0
    [Sep 4, 2010]
    Mine sounds the same on idle, i was told that it's the fsi injectors. It was the same from new. Sounds great when you boot it tho...
    #10
  12. heli_madken
    Offline

    heli_madken Member

    Joined:
    Mar 26, 2008
    Messages:
    117
    Likes Received:
    0
    [Sep 8, 2010]
    Got the car back, engine is pretty much the same, the timing gear and fuel pump parts where supposedly inspected with no faults found but to be honest after my experience with appalling customer service at Shrewsbury Audi I have lost all confidence in them and suspect nothing was done, they replaced the alternator as the bearings where shot which has helped but the engine sounds pretty much the same.

    When I went to collect the car the day I bought it the salesman filled in a blank PDI document in front of me claiming the oringinal had been lost, I dont believe for one second the vehicle was PDI'ed as the clutch switch fault and alternator would have been obvious.

    See my thread on detailing for the other faults

    My advice - stay away from Shrewsbury Audi
    #11
  13. heli_madken
    Offline

    heli_madken Member

    Joined:
    Mar 26, 2008
    Messages:
    117
    Likes Received:
    0
    [Sep 8, 2010]
    Doesnt help that they have left off the acoustic cover!, didnt even realise with all the frustration, I cannot believe that place after all that I have been through
    #12
  14. heli_madken
    Offline

    heli_madken Member

    Joined:
    Mar 26, 2008
    Messages:
    117
    Likes Received:
    0
    [Oct 14, 2010]
    The car has developed a massive stutter this morning and the emission warning light has come on, doesnt sound too bad at tickover but anything else it sounds terrible. It may just be a coil pack but the last time I had one go on the S4 there was a distinctive burning smell

    Can anyone tell me the symptoms of a coil pack going, is a four pot still driveable, managed to make it half a mile to work

    This will be the third time the car has gone back in 2 months of ownership, am I fed up with this car or what
    #13

Share This Page