1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help please??? 2.0 140 Diesel

MarkTweedley Jul 26, 2011

  1. MarkTweedley

    MarkTweedley Member

    144
    0
    16
    Driving to work this morning and accelerated in 2nd gear and car stopped revving at about 4000rpm so I changed up a gear and noticed that after 2500rpm the car is majorly slow to accelerate and build up revs. Still drives and gets faster but takes an age!

    Any ideas folks? Any help appreciated, thanks.
     
  2. MarkTweedley

    MarkTweedley Member

    144
    0
    16
    Might add, this is in every gear.
     
  3. RedDejavu

    RedDejavu Well-Known Member

    1,806
    337
    83
    turbo gone? Common fault on 140tdi
     
  4. MarkTweedley

    MarkTweedley Member

    144
    0
    16
    No smoke and hasn't been any leading up to problem however the turbo has been very vocal lately, almost like a siren sounding whistle. Bugger, I guess my turbo has gone. If it is turbo, is it just the turbo I need to replace, if not, what else?

    Thanks
     
  5. A1DEYB

    A1DEYB Well-Known Member

    1,682
    43
    48
    Nope doesn't mine the turbo has gone, check the air mass meter and check for boost leaks.

    Best bet is to have a diagnostics check done with VCDS or the equivalent.
     
  6. MarkTweedley

    MarkTweedley Member

    144
    0
    16
    Ok cool. Do you have VCDS? Thanks
     
  7. A1DEYB

    A1DEYB Well-Known Member

    1,682
    43
    48
    Sorry i don't but plenty on here do.
     

Share This Page