1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

(help) Oil pressure warning problem

terrya4 Feb 21, 2010

  1. terrya4

    terrya4 New Member

    3
    0
    1
    I bought a 2005(55) A4 2.0tdi 140bhp s-line 6 months ago, it had full dealer service history and had done 97k miles. It has now done 102k and i had it serviced at 99k and the oil presure warning indication has come on, I took into the garage that done my service (which is a private audi/vw specialist) they done a pressure test which came back with a result of 4bar, tried a new switch and done a diagnostic which showed no fault.

    I then took it to a VW dealership which is Audi approved who also ran a diagnostic and renewed the pressure switch, that hasn`t changed anything either and they are not sure where to go next whith the fault finding.

    Does anyone have any idea what could be causing this or what to investigate next

    Please help
     
  2. B5NUT

    B5NUT Well-Known Member VCDS Map User quattro Audi A6 Audi Avant Owner Group S-line owners group

    3,705
    643
    113
    The only thing I can think of, would be to get vag-com and log the oil pressure over trip which would set off the warning light. This would give the garrage a good idea on what the fault could be. Other than that the things I would check, is the wiring going to the pressure switch and the Crankcase breather hose.
     
  3. Wrath

    Wrath Well-Known Member

    1,196
    41
    48
    And presumably you have a BLB engine so may be heading for the oil balance shaft problem. Does it make a rattly noise at all?
     

Share This Page