1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help Needed with my A4, please...

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by DJM1982, Feb 24, 2010.

  1. DJM1982
    Offline

    DJM1982 Member

    Joined:
    Nov 4, 2009
    Messages:
    395
    Likes Received:
    3
    [Feb 24, 2010]
    I got in my 2006 audi A4 S-line yesterday at work. Started it up as normal and the stereo didn't come on, pressed the on button on the stereo and the stereo came to life but none of the display on the dash and none of the buttons on the steering wheel were working. I stopped at the services on the way home and turned the ignition off and the stereo stayed on, i had to turn it off by pressing the button again on the stereo.
    Spoke to my mechanic when i got in and he said it could be something to do with the coil behind the steering wheel and could potentailly be very exprensive to fix.

    Anyone else had this problem or an idea for a diagnosis and cost??

    Cheers in advance for your help.
    #1
  2. Ads

    Ads

    [Sep 16, 2014]

  3. pjmspeedy
    Offline

    pjmspeedy Dude, what's mine say ?

    Joined:
    Apr 29, 2008
    Messages:
    1,058
    Likes Received:
    1
    [Feb 24, 2010]
    Not heard of this before but I guess your first step would be to get it pugeed into vagcom to see if any errors are listed.
    #2
  4. Nitrouslover
    Offline

    Nitrouslover New Member

    Joined:
    Jan 4, 2010
    Messages:
    9
    Likes Received:
    0
    [Feb 26, 2010]
    I have the same problem with my stereo. I have to turn it on and off manually and the button lights do not light up :(

    Hopefully I'll grab the error codes next week, so I'll let you know if I get to the bottom of it.
    #3

Share This Page