1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help needed please A4 door lights

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by grabread, Jul 21, 2012.

  1. grabread
    Offline

    grabread New Member

    Joined:
    Jul 11, 2012
    Messages:
    6
    Likes Received:
    0
    [Jul 21, 2012]
    Hello, I have wired in some door / puddle lights but I cant turn them on. I know some threads say they just closed the door and they came on. The rear ones did but the fronts are stubbornly staying off I have tried wiring in to pin 13 and also pin 17 as the live neither seems to work. Do they need to be enabled somehow or am I doing something wrong? Its a late 2007 model

    Many thanks
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. Gazthesparky
    Offline

    Gazthesparky Member VCDS Map User

    Joined:
    Dec 28, 2011
    Messages:
    195
    Likes Received:
    12
    [Jul 22, 2012]
    Hi

    I'm not sure on the 4door A4 but I know according to Robins DIY mod thread you might have to switch on the door lights using VCDS

    But when I installed them into my A4 cab I had the same problem as you. I found though that I had to plug the grey plug back into the door module the remove the power plug to the module. Then plug it back in and it resets the module

    I think the module switches off the outputs if it doesn't detect a load from the light once it switches off it needs the module to be reset to reset the light output

    Check out this thread for info http://www.audi-sport.net/vb/a3-s3-...my-diy-guide-retro-fitting-puddle-lights.html
    #2
  4. grabread
    Offline

    grabread New Member

    Joined:
    Jul 11, 2012
    Messages:
    6
    Likes Received:
    0
    [Jul 22, 2012]
    Many thanks for the advice, but I have tried the method of removing the power supply but still no good!!
    I am going to try the nearside front door today and see if that will initialise.

    many thanks
    #3
  5. Gazthesparky
    Offline

    Gazthesparky Member VCDS Map User

    Joined:
    Dec 28, 2011
    Messages:
    195
    Likes Received:
    12
    [Jul 22, 2012]
    Have you checked they are enabled via vcds?
    #4
  6. grabread
    Offline

    grabread New Member

    Joined:
    Jul 11, 2012
    Messages:
    6
    Likes Received:
    0
    [Jul 22, 2012]
    Nearside ones work ok so I guess its a wiring or door controller fault. I dont think you can enable them via vcds like on the A3.
    Any ideas ?
    #5
  7. Gazthesparky
    Offline

    Gazthesparky Member VCDS Map User

    Joined:
    Dec 28, 2011
    Messages:
    195
    Likes Received:
    12
    [Jul 22, 2012]
    It's either a wiring fault or a coding problem are you sure you are connecting to the correct pins for your car and are the bulbs pushed in correctly ?

    Can you test you have got a supply with a multimeter ?
    #6
  8. grabread
    Offline

    grabread New Member

    Joined:
    Jul 11, 2012
    Messages:
    6
    Likes Received:
    0
    [Jul 22, 2012]
    Solved!! pin 13 in the door controller was bent flat, presumably from manufacture? stood it back up and all is now well.
    thanks Gaz for your suggestions.
    For the benefit of anyone attempting this pin 13 live pin 21 earth for the front doors, and you will need 000 979 009Erepair wires to fit in the multi plugs same ones fit front and rear doors.
    :blow:
    #7
  9. Gazthesparky
    Offline

    Gazthesparky Member VCDS Map User

    Joined:
    Dec 28, 2011
    Messages:
    195
    Likes Received:
    12
    [Jul 23, 2012]
    Cool glad you got it sorted:)
    #8

Share This Page