1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help needed! Oil pressure light TQS

Discussion in 'A4/S4 forum(B5 Chassis)' started by jgttdi, Mar 25, 2013.

  1. jgttdi

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    Hi everyone, my A4 hasn't been driven for a month so I took it for a run today, after around 2 miles of driving the red oil pressure light came on, I quickly stopped and switched the engine off and on again but the light has came back on, drove home and the car sounds like a tractor (ticking away) I have checked the oil level and that's fine, also my oil temperature gauge has never worked since owning the car.


    Please help, any advice would be great.

    Sorry if this question has been asked before.
     
  2. Advert Guest Advertisement


  3. Mike B

    Mike B Well-Known Member

    Joined:
    Jul 10, 2007
    Messages:
    1,069
    Likes Received:
    39
    Sounds like pump failure
     
  4. gen.heinz guderian

    gen.heinz guderian Well-Known Member
    VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,346
    Likes Received:
    125
    Was there a beeping or buzzer as well?
     
  5. jgttdi

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    I hope not, the car was running perfect, I always let it idle up to temperature before driving it, just seems out of the blue that its happened.
     
  6. jgttdi

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    Yes when the light came on the dash I beeped 3 times as a warning.
     
  7. gen.heinz guderian

    gen.heinz guderian Well-Known Member
    VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,346
    Likes Received:
    125
    Sounds like oil pump pick up blocked /sludged up and starved pump.
    You could take sump off and check if its sludged up and clean pick up pipe.
     
  8. aragorn

    aragorn "Stick a V8 in it!"
    Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    17,580
    Likes Received:
    641
    If its over 100k just stick a new pump in when its apart. That light means "turn it off immediately" So you'll have to hope you've not damaged anything else!
     
  9. jgttdi

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    Would doing an engine flush help at all? Or would running the engine during the flush cause more damage?
     
  10. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,494
    Likes Received:
    646
    no needs the pick up cleaning or changing
    i recon you have took the turbo out at least.
    as above means do not drive
     
  11. jgttdi

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    What you mean took the turbo out?

    The drive home was only 2 miles maximum, so dropping the sump is the only protocol?

    Thanks
     
  12. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,494
    Likes Received:
    646
    2 mile with the no oil preasure can be very bad
    yes sump off and clean as above if its high miles think about changing the pump aswell
     
  13. jgttdi

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    Ok I will try that, I hope the turbo isn't goosed as well.

    would it be best to fit a genuine oil pump or has anyone has any experience with eBay ones?
     
  14. jgttdi

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    What oil would everyone recommend to use after replacing the oil pump?

    Thanks again everyone :)
     
  15. griswold

    griswold Member

    Joined:
    Jan 25, 2008
    Messages:
    345
    Likes Received:
    5
    5W40 fully syn regular changes and fit the larger oil filter
     
  16. griswold

    griswold Member

    Joined:
    Jan 25, 2008
    Messages:
    345
    Likes Received:
    5
    eurocarparts large oil filter for 1.8tqs 501440080 £9 free with their own brand oil
     
  17. jgttdi

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    So the sump is now off, the oil pick up pipe is blocked up by all the sludge etc, would you all advise changing the oil pump?

    Has anyone used non genuine pumps?
     
  18. gen.heinz guderian

    gen.heinz guderian Well-Known Member
    VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,346
    Likes Received:
    125
    I would fit new oil pump. Genuine would be better.No idea how much they are though.
     
  19. Bradderz_1988

    Bradderz_1988 Dont replace it, Upgrade it !!

    Joined:
    Aug 19, 2010
    Messages:
    3,788
    Likes Received:
    205
  20. jgttdi

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    Thought I would update things here, had a few issues when I bought the A4 a few months back, so far I have changed the oil pump, thermostat, coolant temp sensor, rear brake pads, service with bigger oil filter and replaced all 4 springs with eibach ones.

    The car is running great now, I will try and set up a build thread ASAP, thanks for everyone who answered my questions.

    Thanks J
     
  21. gen.heinz guderian

    gen.heinz guderian Well-Known Member
    VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,346
    Likes Received:
    125
    Glad to hear its running well now.
     
  22. Advert Guest Advertisement



    to hide this advert.
  23. boost-addict

    boost-addict Active Member

    Joined:
    Aug 22, 2011
    Messages:
    975
    Likes Received:
    36
    yer glad to hear there was no lasting damage
     
  24. jgttdi

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    Yeah no lasting damage thankfully, I just replaced the oil pump and good new oil and all seems well for the last 1000 miles or so.
     

Share This Page