1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help needed! Oil pressure light TQS

Discussion in 'A4/S4 forum(B5 Chassis)' started by jgttdi, Mar 25, 2013.

  1. jgttdi
    Offline

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    Hi everyone, my A4 hasn't been driven for a month so I took it for a run today, after around 2 miles of driving the red oil pressure light came on, I quickly stopped and switched the engine off and on again but the light has came back on, drove home and the car sounds like a tractor (ticking away) I have checked the oil level and that's fine, also my oil temperature gauge has never worked since owning the car.


    Please help, any advice would be great.

    Sorry if this question has been asked before.
    #1
  2. Mike B
    Online

    Mike B Member

    Joined:
    Jul 10, 2007
    Messages:
    773
    Likes Received:
    8
    Sounds like pump failure
    #2
  3. gen.heinz guderian
    Offline

    gen.heinz guderian Well-Known Member Regional Rep

    Joined:
    Jun 24, 2011
    Messages:
    1,359
    Likes Received:
    125
    Was there a beeping or buzzer as well?
    #3
  4. jgttdi
    Offline

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    I hope not, the car was running perfect, I always let it idle up to temperature before driving it, just seems out of the blue that its happened.
    #4
  5. jgttdi
    Offline

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    Yes when the light came on the dash I beeped 3 times as a warning.
    #5
  6. gen.heinz guderian
    Offline

    gen.heinz guderian Well-Known Member Regional Rep

    Joined:
    Jun 24, 2011
    Messages:
    1,359
    Likes Received:
    125
    Sounds like oil pump pick up blocked /sludged up and starved pump.
    You could take sump off and check if its sludged up and clean pick up pipe.
    #6
  7. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,495
    Likes Received:
    299
    If its over 100k just stick a new pump in when its apart. That light means "turn it off immediately" So you'll have to hope you've not damaged anything else!
    #7
  8. jgttdi
    Offline

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    Would doing an engine flush help at all? Or would running the engine during the flush cause more damage?
    #8
  9. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep

    Joined:
    Jul 8, 2008
    Messages:
    8,706
    Likes Received:
    489
    no needs the pick up cleaning or changing
    i recon you have took the turbo out at least.
    as above means do not drive
    #9
  10. jgttdi
    Offline

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    What you mean took the turbo out?

    The drive home was only 2 miles maximum, so dropping the sump is the only protocol?

    Thanks
    #10
  11. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep

    Joined:
    Jul 8, 2008
    Messages:
    8,706
    Likes Received:
    489
    2 mile with the no oil preasure can be very bad
    yes sump off and clean as above if its high miles think about changing the pump aswell
    #11
  12. jgttdi
    Offline

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    Ok I will try that, I hope the turbo isn't goosed as well.

    would it be best to fit a genuine oil pump or has anyone has any experience with eBay ones?
    #12
  13. jgttdi
    Offline

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    What oil would everyone recommend to use after replacing the oil pump?

    Thanks again everyone :)
    #13
  14. griswold
    Offline

    griswold Member

    Joined:
    Jan 25, 2008
    Messages:
    341
    Likes Received:
    5
    5W40 fully syn regular changes and fit the larger oil filter
    #14
  15. griswold
    Offline

    griswold Member

    Joined:
    Jan 25, 2008
    Messages:
    341
    Likes Received:
    5
    eurocarparts large oil filter for 1.8tqs 501440080 £9 free with their own brand oil
    #15
  16. jgttdi
    Offline

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    So the sump is now off, the oil pick up pipe is blocked up by all the sludge etc, would you all advise changing the oil pump?

    Has anyone used non genuine pumps?
    #16
  17. gen.heinz guderian
    Offline

    gen.heinz guderian Well-Known Member Regional Rep

    Joined:
    Jun 24, 2011
    Messages:
    1,359
    Likes Received:
    125
    I would fit new oil pump. Genuine would be better.No idea how much they are though.
    #17
  18. Bradderz_1988
    Offline

    Bradderz_1988 Dont replace it, Upgrade it !!

    Joined:
    Aug 19, 2010
    Messages:
    3,163
    Likes Received:
    100
    #18
  19. jgttdi
    Offline

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    Thought I would update things here, had a few issues when I bought the A4 a few months back, so far I have changed the oil pump, thermostat, coolant temp sensor, rear brake pads, service with bigger oil filter and replaced all 4 springs with eibach ones.

    The car is running great now, I will try and set up a build thread ASAP, thanks for everyone who answered my questions.

    Thanks J
    #19
  20. gen.heinz guderian
    Offline

    gen.heinz guderian Well-Known Member Regional Rep

    Joined:
    Jun 24, 2011
    Messages:
    1,359
    Likes Received:
    125
    Glad to hear its running well now.
    #20
  21. boost-addict
    Offline

    boost-addict Member

    Joined:
    Aug 22, 2011
    Messages:
    979
    Likes Received:
    35
    yer glad to hear there was no lasting damage
    #21
  22. jgttdi
    Offline

    jgttdi Member

    Joined:
    Jan 5, 2013
    Messages:
    60
    Likes Received:
    0
    Yeah no lasting damage thankfully, I just replaced the oil pump and good new oil and all seems well for the last 1000 miles or so.
    #22

Share This Page