1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

help needed (COOLANT WARNING)

Discussion in 'A3/S3/Sportback (8P Chassis)' started by gixxer600k4, Feb 22, 2010.

  1. gixxer600k4
    Offline

    gixxer600k4 Member

    Joined:
    Feb 19, 2009
    Messages:
    692
    Likes Received:
    0
    hiya guys, i have recently started to get coolant warning lights flash up at me, first time it happened i pulled over straight away, checked under bonnet and there was plenty of coolant, opened the coolant tank lid and re-fitted it and for some reason, the warning disappeared. this has happened a few times and every time the warning has gone.

    when the warning is up, the engine temp is not being read, and the coolant fans are on. im a bit confused as to why it does this because, if it were the engine temp gauge then why do i get a warning about coolant being low or if it was low coolant, why cant the engine temp be read!!!!

    my car is starting to fall to pieces, the EGR valve needs replaced, both of my keys dont seem to be working even when re-synced!!

    all help appreciated

    thanks,

    matt
    #1
  2. Khufu
    Offline

    Khufu Active Member

    Joined:
    Jan 2, 2003
    Messages:
    5,703
    Likes Received:
    2
    I have heard of the sensor in the expansion tank becoming faulty & going off when fluid is not required. EGR seem Audi's weak spot!
    #2
  3. Ads
    Offline

    Ads License to drive

    Joined:
    Jul 15, 2009
    Messages:
    8,222
    Likes Received:
    9
    I had exactly the same problem.
    One day I turned my car on, received the coolant warning in DIS, and on came the fans.
    Turned car off, checked coolant levels they were not even close to being low.

    Turned car back on, warning still there and fans still going.

    Turned back off, left it for about 10-15 mins, turned back on and everything was back to normal. No warning, no fans.

    Has never happened since, and that was about 10 months ago.

    I've heard of quite a few people with the same problem, and as Khufu said, it was down to the sensor in the expansion/coolant tank.
    Some are lucky enough to not need a replacement as the problem only happened once or twice (a glitch??), other's had to have a new coolant tank fitted.

    If the problem doesn't go maybe try a battery disconnect for half an hour to see if resetting helps.
    #3
  4. gixxer600k4
    Offline

    gixxer600k4 Member

    Joined:
    Feb 19, 2009
    Messages:
    692
    Likes Received:
    0
    it turned off again while i was driving after about ten mins, fans turned off, warning went and then the temp popped up to around 70 and increased to 90 where it normally is.
    could this be because the water was warm and the sensor was able to read the water being there. i have no idea, all these electrics just cause more problems.

    thanks for the help guys, will get that checked out!
    #4
  5. johnnya3
    Offline

    johnnya3 New Member

    Joined:
    Feb 21, 2010
    Messages:
    7
    Likes Received:
    0
    Hi there,i had the exact same problem last year on my A3 and it turned out it was the coolant temperature sensor.

    I replaced this myself and that cured all the problems of the fans coming on,coolant warning light and the temperature guage fluctuating.
    The sensor was about £15

    btw. my egr valve needs sorting out as well!
    #5
  6. bonerp
    Offline

    bonerp Member

    Joined:
    Sep 24, 2007
    Messages:
    180
    Likes Received:
    0
    Hi All,
    My coolant light came on this morning as soon as I started it. Turned it off and back on came on again! Turned off, checked the level (which was just above minimum) and restarted but now it stayed off!
    Suspect it looks from above to be a sensor. Can these sensors be bought without needing to replace the tank? I know they can on Golfs as its a typical problem on those! BTW my ride is A3 2008 2.0 TDI 170 SE Sportswagon
    thanks
    #6
  7. SAiLO
    Offline

    SAiLO Enthusiast

    Joined:
    May 7, 2009
    Messages:
    936
    Likes Received:
    3
    Scrape the two metal rods in the coolant tank with a knife and see if that helps. It may help with your problem.
    #7
  8. tdi-man
    Offline

    tdi-man Active Member

    Joined:
    Jul 27, 2009
    Messages:
    1,610
    Likes Received:
    1
    This happened to me I fitted a new bottle and was sorted never happened again
    #8
  9. bonerp
    Offline

    bonerp Member

    Joined:
    Sep 24, 2007
    Messages:
    180
    Likes Received:
    0
    Garage I bought the car from have said to book it straight into Audi Swindon and they will fix this and the droning issue I have - reeeeesult!
    #9
  10. TDI140
    Offline

    TDI140 Active Member

    Joined:
    May 19, 2011
    Messages:
    1,375
    Likes Received:
    2
    i had this yesterday morning 7am drove down the road for 5 seconds and it went then didnt come up after that i checked the sensor wire they seem fine, cant be an expensive or difficult repair to swap for new sensor ?
    #10

Share This Page