1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help needed ASAP

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by fossie, Oct 18, 2012.

  1. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Oct 18, 2012]
    Hi guys. Basically my misses was driving to work when she noticed the engine management light come on. She stated that all of a sudden the the battery came on and the car lost power and stalled. I've been to the car and it turns over but won't start. I did notice that the brake light was flashing for some reason when I was trying to start it. It doesn't appear to be a snapped belt as it turns over at normal speed.
    I did notice the other day the lights in and out of the car were flickering.

    Anu suggestions until I can get access to vagcom. Currently waiting for the car to be recovered.

    Kind regrads
    lee
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Oct 18, 2012]
    Oh also noticed that when then there is no key in the ignition the engine fan is spinning for some reason
    #2
  4. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Oct 18, 2012]
    Girlfriend just rang. She said she put the radio on now the cars completely dead and won't start over
    #3
  5. Boro&Beth
    Offline

    Boro&Beth Member

    Joined:
    Jun 3, 2009
    Messages:
    172
    Likes Received:
    0
    [Oct 18, 2012]
    Sounds electrical. Battery/Alternator most likely.
    #4
  6. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Oct 19, 2012]
    Apparently there was water in the black casing in the engine bay where there are 3 relays. Garage is going to dry them out. They said that this is a common problem on Audi/Seat etc.

    anyone heard of this before
    #5
  7. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,811
    Likes Received:
    502
    [Oct 19, 2012]
    yes the seal goes
    and the ecu and relays get wet
    quite common.
    #6
  8. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Oct 19, 2012]
    Bez, would drying them out and reseal the unit solve problem
    #7
  9. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,811
    Likes Received:
    502
    [Oct 19, 2012]
    yes it can work
    but it may have ****ed a relay or 2
    #8
  10. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Oct 19, 2012]
    Any ideas how much the relays cost Bez?

    Cheers
    lee
    #9
  11. chrisa4quat
    Offline

    chrisa4quat Member

    Joined:
    Sep 21, 2004
    Messages:
    897
    Likes Received:
    10
    [Oct 20, 2012]
    Normally down to drain holes blocking etc
    #10
  12. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Oct 22, 2012]
    Ok so the garage have rang and said they have dried the relays out and the car still won't start. They said they have also tried 'hard wiring' the fuel pump but again it still won't start.
    Any suggestions. The garage said they are trying an auto electrician but may not be able to get one till Friday.
    Any help/advice would be great
    #11
  13. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,811
    Likes Received:
    502
    [Oct 22, 2012]
    have they scanned it
    any codes ?
    #12
  14. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Oct 22, 2012]
    They said they haven't scanned it. I might go down with my vagcom and plug it in. Ill give them an hour or so
    #13
  15. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,811
    Likes Received:
    502
    [Oct 22, 2012]
    Good garage then ?
    scan it post codes lets see if we can help your garage
    a auto sparkie aint gona be cheap
    and could still be a relay or a fuse etc from the water.
    #14
  16. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Oct 22, 2012]
    Just been down. Transpires that the car would start with the fuel pump hard wired however ran like a bag of ****e. Plugged into vagcom and showed glow plug control module.
    I beleive this means the relays are fooked??
    #15
  17. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Oct 23, 2012]
    Anyone, Bez?
    #16
  18. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,811
    Likes Received:
    502
    [Oct 23, 2012]
    Hmm what i would do is
    get the relays and swap them over
    is the ECU wet (if its in same box as the relays) ?
    my pals just had the glow plug module fault on his passat the car still ran im sure the part was around £60/70.
    i cant see the above module stoping the car from starting tho.
    #17
  19. twist123
    Offline

    twist123 Member

    Joined:
    Jun 7, 2009
    Messages:
    186
    Likes Received:
    0
    [Oct 23, 2012]
    Surely it would stop it though if none of the glow plugs are getting hot?
    #18
  20. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,811
    Likes Received:
    502
    [Oct 23, 2012]
    yes you would think so
    but you have it started with the pump wired direct
    so i would be changeing the relays and looking what else is in the box with the relays.
    #19
  21. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Oct 23, 2012]
    Bez, in the box there are 3 relays (fuel pump, fan and glow plug), the other fuse(s) that were in there were fine. The expensive relay, think its the glow plug one was corroded so looks like it was like this for some time.

    What we did was clear the codes and start the car, it ran but really poorly. Scanned it on VCDS again and it brought up the glow plug fault. Again cleared it and started ot again and the same fault showed.

    I think we are just replacing the relays and taking it from there
    #20
  22. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,811
    Likes Received:
    502
    [Oct 23, 2012]
    yep i know there £££ from audi
    where are you located
    i have a few relays in the yard.
    #21
  23. fossie
    Offline

    fossie Member

    Joined:
    May 1, 2011
    Messages:
    200
    Likes Received:
    1
    [Oct 23, 2012]
    Im from County Durham matey, dont worry about the relays as the garage have ordered them. Im hoping i can argue that this is a warranty job
    #22
  24. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    8,811
    Likes Received:
    502
    [Oct 23, 2012]
    yeah bit to far down to get them to you
    anyway hope the relay sorts it
    get them fo fit the new rubber seal aswell
    #23

Share This Page