1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help needed A4 2.0T engine very rough and no power

Andy D Mar 12, 2010

  1. Andy D

    Andy D Member

    276
    0
    16
    My 2006 2.0 TFSI A4 has been a joy for the last 9 months, I went for a drive tomight and accelerated off of a roundabout, there was an immediate loss in power although the car still drives very slowly, the engine now sounds like a bag os spanners and very lumpy.

    It's quite lumpy on idle and sounds horrific when revving, a bit like a subaru boxer engine with a bad exhaust.

    I had it remapped last summer with no problems at all.

    I've no idea what might be the cause, I've defo not put diesel in it.

    Any help would be fantastic
     
  2. Broken Byzan

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User quattro Audi A4

    13,224
    464
    83
    Coil pack gone. If you get the car scanned on VAGcom it will tell you which cylinder
     
  3. Andy D

    Andy D Member

    276
    0
    16
    I really hope so, I've got images of a Turbo vein in the engine somewhere....eeek!

    I've had it recovered to a local garage who will plug it in to their diagnostics tomorrow morning, I tried Glasgow Audi but they refused to take it after 6pm and stated their bollards would be locked
     
  4. Andy D

    Andy D Member

    276
    0
    16
    Thanks again Byzan, I've just had a call from the garage, the coil pack has gone on cylinder 4.

    Should have the new one delivered on Monday, not got a cost yet but still smiling as I thought it was going to be a humungus problem like a snapped timing belt or turbo blown or something.
     
  5. Broken Byzan

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User quattro Audi A4

    13,224
    464
    83
    Make sure they use a genuine one, pattern ones are not as hardy, and only cost a few more quid. Sub £40 for the part anywho !!
     

Share This Page