1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help! Need update U600 Code Reader

daviscandy Feb 2, 2012

  1. daviscandy

    daviscandy New Member

    4
    0
    1
    I bought this U600 from uobd2 and it does not work with my 2003 VW New Beetle TDI, and I am not able to update it either, I don't know how to deal with the error message, which professionals can help me ???
     

Share This Page