1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help Lost All Electrics

Taza Nov 22, 2012

  1. Taza

    Taza New Member

    19
    0
    1
    Last night driving through Manchester in major trafic,battery alarm came on then lights went out,drove car into car park lost power steering,
    Is there a Alternator fuse if so what size,going back today to see if we can get her going.
    Will take my meter and carry out a few test.

    cheers

    the battery symbol on the dash is on when you switch ignition on then goes out when engine runs ???
     
  2. lloydie1

    lloydie1 Member

    68
    2
    6

    Sounds like the alternator belt has snapped if you lost the power steering as well.
     
  3. Taza

    Taza New Member

    19
    0
    1
    Belt is OK
     
  4. Vex182

    Vex182 Guess what I drive...

    1,035
    79
    48
    This happened to me when my alternator failed at 99k. Best to get it tested, my battery went flat and even a jump start did not help because the car just went flat right away.
     
  5. Taza

    Taza New Member

    19
    0
    1
    Just checked voltage at the battery when engine only 12v,ordered new alternator,removed alternator it's got a weird pulley.never seen one like this,

    Cheers
     
  6. Vex182

    Vex182 Guess what I drive...

    1,035
    79
    48
    Do you mean the pulley on the alternator? It's a clutch type so slips when turned backwards.
     
  7. Taza

    Taza New Member

    19
    0
    1
    Yes on the pulley,the clutch type,but why ???
     
  8. Vex182

    Vex182 Guess what I drive...

    1,035
    79
    48
    No idea, my old one and new ones the same. I fitted the new one 2.5k ago and all has been well. What mileage did yours go at?
     
  9. Taza

    Taza New Member

    19
    0
    1
    100K
     
  10. Sam_

    Sam_ Down under

    3,035
    480
    83
    Did you get strange popping now and then through the stereo before this? I have a feeling mine is going. Having some power issues.
     
  11. Vex182

    Vex182 Guess what I drive...

    1,035
    79
    48
    Mine went without any warning at all. Was just on the motorway at about 60mph, the car beeped and he battery light came up and within 2-3 miles later it all died and I coasted to a stop, could not even reach the next junction to get off at :( Strange that yours went at the same mileage, I was 99,970!
     

Share This Page