1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP! Indicators playing silly buggers!

1210tech Feb 5, 2007

  1. 1210tech

    1210tech Four Ring Fanatic

    692
    1
    18
    Just noticed the other night that when I indicate to turn right the indicators flash right once then flash left two to three times and then reset and flash right again until i switch them off. It only does it when I first start indicating.

    It doesn't do it all the time but when it does I am worried someone is gonna pull out on me because they think I am going to turn left when I am actually turning right! :scared2:

    What the hell could it be, is it the relay or is it the stalk mechanism that is knackered?
     
  2. WHITEY_1

    WHITEY_1 Member

    229
    0
    16
    HI tech I had this problem on my n reg I was told to hit the hazard warning switch quite hard with your finger I tried it and it worked sweet as a nut! Hope this helps!
     
  3. 1210tech

    1210tech Four Ring Fanatic

    692
    1
    18
    you reckon its a loose connection then? I imagine that push the switch back onto some kind of connection?
     
  4. WHITEY_1

    WHITEY_1 Member

    229
    0
    16
    I dont know about a loose connection BUT i remember that before it happened i cleaned the car in side and i think where i was cleaning it {the dash} i must of jammed the hazard switch then later i went out in the car and thats when it started playing up i then came back home put a post on the forum then they told me what to do the same as i told you and it worked
    Have you gone out and tried it yet?
     
  5. 1210tech

    1210tech Four Ring Fanatic

    692
    1
    18
    not yet, the mrs is out in it at the mo but as soon as she comes back i will try it and let you know
     
  6. WHITEY_1

    WHITEY_1 Member

    229
    0
    16
  7. 1210tech

    1210tech Four Ring Fanatic

    692
    1
    18
    hi whitey, thanks for givin your comments and I have tried what you said but it hasn't made any difference. I am starting to think more and more that its the stalk thats faulty, I don't think its making the proper contact when I move it up to turn right.

    Does anyone know how much a stalk would be to replace and do you just replace the one or does it come as a unit with both stalks?
     
  8. WHITEY_1

    WHITEY_1 Member

    229
    0
    16
    DAMN! no problem tech hope you sort it
     
  9. 46TheDoctor

    46TheDoctor Valentino Rossi A.K.A The Doctor

    312
    1
    16
    A good friend of mine is an audi technician and i put your problem too him, he said that the hazard switch is the control ecu for all your indicaters, he says he has to frequently replace these under warranty and is sure this is your problem.
     
  10. chris_20

    chris_20 Member

    707
    2
    16
    sounds like a promising piece of advice, hope u get it sorted easily mate
     
  11. 1210tech

    1210tech Four Ring Fanatic

    692
    1
    18
    thanks for that mate but i think its sorted itself out.
    i noticed the other day that while i was turning the steering wheel left to go around an island i pushed the stalk upwards to turn right and there was a louder click than usual as if something snapped back into position and now the problem has stopped happening?!?!?!?!? god knows what it was but the indicators are working as they should be again....bloody cars!
     
  12. chris_20

    chris_20 Member

    707
    2
    16
    bet audi didnt know they made self righting cars
     
  13. 1210tech

    1210tech Four Ring Fanatic

    692
    1
    18
    don't tell 'em, they will be asking for money for that as well!!!
     
  14. chris_20

    chris_20 Member

    707
    2
    16

Share This Page