1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP....indicator and wiper stalks stopped working!!

S3 Rav Sep 14, 2011

  1. S3 Rav

    S3 Rav Well-Known Member

    2,825
    30
    48
    Right guys any help would be much appreciated.

    was driving as usual earlier when i noticed my indicators werent flashing from the inside..or outside. Thought that the relay switch had gone again no problem I'll change it. Then it started to drizzle, tried to put the wipers on and they're not working.

    Tried to also put my main lights on as it was getting dark and guess what...they're not working.

    Have just got home to check the fuses and they all seem to be working fine so now im stuck.

    Help!!
     
  2. Maz

    Maz Moon is made of green cheese

    1,002
    10
    38
    Not sure if it will help but have you checked the fuses above the battery as well?
     
  3. Dani_B19

    Dani_B19 Audi-sports own special child.

    9,343
    394
    83
    Isnt their a realy under the steering wheel that can go and cause trouble?
     
  4. S3 Rav

    S3 Rav Well-Known Member

    2,825
    30
    48
    maz: fuses ontop of the battery only seem to do with abs stuff as im seeing looking through the handbook.
    Dan: do you know how easy this would be to fix?
     
  5. Dani_B19

    Dani_B19 Audi-sports own special child.

    9,343
    394
    83
    If it is that, then just take the lower dash off and replace the relay.
     
  6. Gops

    Gops Badger 5 Edition VCDS Map User Gold Supporter Audi S3

    3,198
    666
    113
    Let me know if you need anything tomrrow rav, im off from work!
     
  7. Gops

    Gops Badger 5 Edition VCDS Map User Gold Supporter Audi S3

    3,198
    666
    113

Share This Page