1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help! EGR delete kit.

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Greeny233, Jun 2, 2012.

  1. Greeny233
    Offline

    Greeny233 Active Member

    Joined:
    Mar 17, 2011
    Messages:
    755
    Likes Received:
    138
    [Jun 2, 2012]
    Hi all.

    This morning I fitted an Allard egr delete kit on my 1.9tdi Quattro avant. The kit fitted ok except the samco turbo hose didn't fit so I had to remove the metal sleeve from the standard hose and use that, but anyway, started the car after fitting and it was all fine and ran well went for a drive and the car felt a bit more responsive but the engine management light has come on and it's a little rough at tick over. Just wondering if I need to blank off the two hoses I have removed from the egr? (instructions said to just leave them to atmosphere).
    #1
  2. Ads

    Ads

    [Dec 29, 2014]

  3. stu_m
    Offline

    stu_m Well-Known Member VCDS Map User

    Joined:
    Oct 25, 2009
    Messages:
    1,442
    Likes Received:
    36
    [Jun 2, 2012]
    What year car is it? Some are in with the ecu and removing brings on the EML it sounds like yours is like this

    Not sure if there is a way round it to be honest

    I know a lot of people reduce the amount of exhaust gases her recirculated through VCDS
    #2
  4. Greeny233
    Offline

    Greeny233 Active Member

    Joined:
    Mar 17, 2011
    Messages:
    755
    Likes Received:
    138
    [Jun 2, 2012]
    It's a 2004 year.
    #3
  5. stu_m
    Offline

    stu_m Well-Known Member VCDS Map User

    Joined:
    Oct 25, 2009
    Messages:
    1,442
    Likes Received:
    36
    [Jun 2, 2012]
    #4
  6. hades-
    Offline

    hades- Yorkshire & Humber Rep. Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,078
    Likes Received:
    558
    [Jun 2, 2012]
    you will need it writeing out of the ECU
    any good remapper should sort it for you
    #5
  7. Greeny233
    Offline

    Greeny233 Active Member

    Joined:
    Mar 17, 2011
    Messages:
    755
    Likes Received:
    138
    [Jun 2, 2012]
    thanks. Thinking of having it remapped anyway so when I have it done I'll see if they can write it out.
    #6
  8. pauldazzle
    Offline

    pauldazzle Active Member

    Joined:
    Nov 11, 2009
    Messages:
    749
    Likes Received:
    40
    [Jun 3, 2012]
    You'll probably find that the EML will go off after a few driving cycles, but will come on again after a few more cycles, & so on. After a couple of months I got fed up with the EML constantly going on & off.
    If you ever get down to S Wales there's a guy called Chris Hughes at Total Tuning who can write it out, & charges £50.
    #7
  9. tommytonguedj
    Offline

    tommytonguedj Member

    Joined:
    Apr 25, 2012
    Messages:
    131
    Likes Received:
    2
    [Jun 3, 2012]
    I fitted an allard delete kit last week to my 1.9 tdi first i cut the original hose too short so i had to bin that so was without a car for 2 days. And the blue silicone hose i ordered off fleabay was 57 to 51mm 90 degree bend and was £11.30 incl p&p no light and car feels loads better.
    #8
  10. mattyboyc
    Offline

    mattyboyc Well-Known Member

    Joined:
    Sep 8, 2009
    Messages:
    1,329
    Likes Received:
    37
    [Jun 3, 2012]
    Any chance you can post a link to the hose you bought? i did my allard job a while ago and have had the hose blow off once, so have been meaning to replace with a slightly longer one,
    Cheers,
    Matt
    #9
  11. tommytonguedj
    Offline

    tommytonguedj Member

    Joined:
    Apr 25, 2012
    Messages:
    131
    Likes Received:
    2
    [Jun 3, 2012]
    Hi Matt, Sorry it was £13.30 the first one i ordered was £11.30 after the wifes measuring skills, Here it is mate not too bad for the price just need to figure out now haw to change all my hoses to silicone now the vacuum and that is blue. eBay - The UK's Online Marketplace
    Last edited: Jun 3, 2012
    #10
  12. mattyboyc
    Offline

    mattyboyc Well-Known Member

    Joined:
    Sep 8, 2009
    Messages:
    1,329
    Likes Received:
    37
    [Jun 3, 2012]
    Thanks very much for that, I'll order one of those.
    Matt
    #11
  13. tommytonguedj
    Offline

    tommytonguedj Member

    Joined:
    Apr 25, 2012
    Messages:
    131
    Likes Received:
    2
    [Jun 3, 2012]
    #12
  14. 666markyboy
    Offline

    666markyboy Well-Known Member

    Joined:
    Mar 17, 2008
    Messages:
    1,131
    Likes Received:
    34
    [Jun 4, 2012]
    To the original post.... are those 2 pipes not vacuum pipes ???? if so then they need to be blocked off otherwise as it will be sucking in air and that's probably whats causing the rough idle
    #13
  15. pauldazzle
    Offline

    pauldazzle Active Member

    Joined:
    Nov 11, 2009
    Messages:
    749
    Likes Received:
    40
    [Jun 4, 2012]
    Yeah agreed. Can't see how you could still have vacuum with those 2 pipes left unplugged.
    #14
  16. Greeny233
    Offline

    Greeny233 Active Member

    Joined:
    Mar 17, 2011
    Messages:
    755
    Likes Received:
    138
    [Jun 4, 2012]
    the instructions say to leave the pipes to atmosphere, i was going to plug them up but after a couple of drives the idle is now fine and the car pulls a lot better, there is a noticeable difference in perfomance especially at the bottom end.
    For now i'll live with the EML being on until i can get it remapped.
    #15
  17. scottshere
    Offline

    scottshere Member

    Joined:
    Dec 9, 2010
    Messages:
    339
    Likes Received:
    2
    [Jun 4, 2012]
    I plugged mine with a golf tee. Think i heard from a few people that this is what you have to do
    #16
  18. tommytonguedj
    Offline

    tommytonguedj Member

    Joined:
    Apr 25, 2012
    Messages:
    131
    Likes Received:
    2
    [Jun 4, 2012]
    i just put screws in both of mine, Strange though how it's hit and miss with eml light, I took my intake manifold off when i was doing mine and cleaned it over a weekend. Also b looks so much better with the big daft egr gone.
    #17
  19. rawtor51
    Offline

    rawtor51 Active Member

    Joined:
    Jan 4, 2011
    Messages:
    299
    Likes Received:
    33
    [Jun 4, 2012]
    mines a 04 reg too, i blanked the egr off, felt nice to drive but, same as you the light come on, got fed up seeing it so i too my blank out again.
    #18
  20. Greeny233
    Offline

    Greeny233 Active Member

    Joined:
    Mar 17, 2011
    Messages:
    755
    Likes Received:
    138
    [Jun 5, 2012]
    well today i plugged up the two vacuum hoses and it hasn't made any difference to the running. Tomorrow i'm going to take it to my friends garage and borrow his diagnostic computer and reset the fault codes and see what happens.
    Also today bought a samco 51mm to 57mm 90 degree elbow and a couple of mikalor clamps, more for the aesthetics than anything.
    #19
  21. mattyboyc
    Offline

    mattyboyc Well-Known Member

    Joined:
    Sep 8, 2009
    Messages:
    1,329
    Likes Received:
    37
    [Jun 6, 2012]
    Where did you get your pipe and clamps?
    Cheers
    matt
    #20
  22. Greeny233
    Offline

    Greeny233 Active Member

    Joined:
    Mar 17, 2011
    Messages:
    755
    Likes Received:
    138
    [Jun 7, 2012]
    Matt - I got the pipe and clamps from my old work place Demon Tweeks they carry the Samco elbow's in stock. Not the cheapest but it was only £26 all in.
    #21

Share This Page