1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help! A4 2.0Tdi S line...

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by vavavag, Jun 25, 2013.

  1. vavavag
    Offline

    vavavag Member

    Joined:
    Dec 9, 2011
    Messages:
    51
    Likes Received:
    0
    [Jun 25, 2013]
    Just bought a late 2005 b7 a4 2.0tdi S line 140.
    Car drives very well, accelerates pretty good to.

    HOWEVER...

    1. When put into high gear and in low revs the car judders violently until about 2k revs and then just accelerates normally. When the car is in 6th gear at around 1200-1300 revs upon acceleration it shakes quite bad. This then stops at 2k revs and the car drives normally.

    2. At idle the car also shakes a little.

    I have had one of these before with an oil pump issue so know what thats like - my last one would shake and judder hard on acceleration no matter the position of rev counter. This car however is smooth high in the revs and will easily go over 80mph!

    What do you guys think it is? Quite worried.

    Any help much appreciated

    Thanks in Advance!
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. claudefrog
    Offline

    claudefrog Member

    Joined:
    Dec 13, 2006
    Messages:
    372
    Likes Received:
    1
    [Jun 25, 2013]
    Flywheel judder?
    #2
  4. brownie 25
    Offline

    brownie 25 Member

    Joined:
    Apr 13, 2010
    Messages:
    347
    Likes Received:
    7
    [Jun 25, 2013]
    does it make any difference when you press the clutch at idle
    #3
  5. vavavag
    Offline

    vavavag Member

    Joined:
    Dec 9, 2011
    Messages:
    51
    Likes Received:
    0
    [Jun 25, 2013]
    No difference when pressing clutch. No rattle or play from flywheel when cutting car out. Judder at low revs when accelerating. Friend thinks it may be injector harness?
    #4
  6. Conmase
    Offline

    Conmase New Member

    Joined:
    Mar 10, 2013
    Messages:
    3
    Likes Received:
    0
    [Jun 26, 2013]
    I have the same problem and I have been told its injectors
    #5
  7. gen.heinz guderian
    Offline

    gen.heinz guderian Well-Known Member Regional Rep VCDS Map User

    Joined:
    Jun 24, 2011
    Messages:
    1,359
    Likes Received:
    125
    [Jun 26, 2013]
    Dont think the car will like being put into 6th at 1200 rpm,no wonder it judders.
    #6
  8. vavavag
    Offline

    vavavag Member

    Joined:
    Dec 9, 2011
    Messages:
    51
    Likes Received:
    0
    [Jun 26, 2013]
    I had the car put on diagnostic and comes up as misfire in cylinder 4. p0304 or something along those lines.
    Could this mean injector? or injector harness? Put into high gear at even 14-1500 revs the car shakes hard!
    #7
  9. vavavag
    Offline

    vavavag Member

    Joined:
    Dec 9, 2011
    Messages:
    51
    Likes Received:
    0

Share This Page