1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP!! 2007 S3 BLUETOOTH MODULE FAILED!

Discussion in 'A3/S3/Sportback (8P Chassis)' started by S321BAD, Mar 19, 2013.

  1. S321BAD
    Offline

    S321BAD Member

    Joined:
    Feb 11, 2013
    Messages:
    43
    Likes Received:
    2
    Hi All,

    i am a relative newbie to the forum so please forgive any lack of knowledge!

    i am from South Manchester and i have a 2007 S3 with factory fitted RNS-e with bluetooth/voice control and multi function steering wheel. i called my local dealer to confirm this was all factory fitted.

    anyway, all was fine up until last weekend and all of a sudden the telephone function on my rnse displayed the message 'telephone not available' as opposed to the usual pause/beep when you get in the car. i have an Iphone 5 - the bluetooth works fine, but for precaution i tried it in my brothers Mercedes with parrot kit and it worked fine. so i tried resetting the phone and trying different phones with no luck. also tried holding down the radio and setup buttons on the rnse - still no luck.

    Later that evening i went to my car only to discover my battery was completely flat - had no option but to call the RAC, they diagnosed a faulty battery and this was replaced with a fresh battery. didnt think there was any correlation to the bluetooth module but it was a coincidence as these are the first 2 issues ive had with the car! a few days later i took the car to a freind to get the codes read on the car and it came up 'no communication' on VAGCOM relating to the telephone module. so i set about searching ebay for a second hand bluetooth module. Meanwhile, my brand new battery went flat again - called the RAC again and told them i thought it was something to do with the bluetooh draining my battery. they got the car started and then with everything off - tested for a drain.

    indeed as my suspisons confirmed - there was a 4 amp drain on the battery - so the RAC set about finding the fuse for the bluetooth and removed it. even after removing that fuse there was still a 2 amp drain?!? he didnt have time to check all the fuses and i didnt hvae the handbook on me so not wanting to take too many risks he said its best i drive home (the long way) and disconnect my battery everytime i plan to leave the car stood for a while.

    i have ordered an 8P0862335H from ebay which has been delivered today. now i cant find a garage that will fit a used part?? does anyone have any experience/reccomendations regarding this fault? can anyone reccomend anywhere (local) and reasonable i can go and get this issue sorted?
    what about the bluetooth module? why would that fail all of a sudden??? any help/comments would be much appreicated!
    #1
  2. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,235
    Likes Received:
    1,220
    Welcome to the forum.

    Have you had the battery go flat still since the BT module was disconnected, assuming you're not still unplugging the battery.

    TBH you should of gone with latest module version to be fully compatible with the latest handsets.

    I can install the BT module, also have latest versions available.

    Send me a PM if services are of use.
    #2
  3. Blackie
    Offline

    Blackie Active Member

    Joined:
    Feb 6, 2004
    Messages:
    663
    Likes Received:
    53
    I have a spare one in the garage but cant remember what version

    I am near Bolton if you need a scan but NHN is yer man for the coding of anything
    #3
  4. S321BAD
    Offline

    S321BAD Member

    Joined:
    Feb 11, 2013
    Messages:
    43
    Likes Received:
    2
    Cheers for the quick responses NHN and Blackie,

    i need the new module fitting and coding. NHN i have sent you a private message.

    i havent had the battery go flat since disconnecting the BT fuse as i have been disconnecting the battery at the end of every journey...
    #4
  5. S321BAD
    Offline

    S321BAD Member

    Joined:
    Feb 11, 2013
    Messages:
    43
    Likes Received:
    2
    does anybody else have any experience of bluetooth module failing??
    #5
  6. S321BAD
    Offline

    S321BAD Member

    Joined:
    Feb 11, 2013
    Messages:
    43
    Likes Received:
    2
    thanks for your help NHN! much appreciated
    #6
  7. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,235
    Likes Received:
    1,220
    No worries mate, glad I could be of help.

    Any updates as yet as been 3 days now :)
    #7
  8. S321BAD
    Offline

    S321BAD Member

    Joined:
    Feb 11, 2013
    Messages:
    43
    Likes Received:
    2
    All seems to be fine up to now!
    car has been sat on my drive since friday night as i have been away without the car - so plenty of time for the battery to drain. but started first time this morning with no issues so far (touch wood!) phone connected to bluetooth almost instantly so all is well!
    #8
  9. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,235
    Likes Received:
    1,220
    Good news, glad to hear it :)

    The immo related fault logged is usually resolved via a module swap out mate as advised, spoke with audi friend & he says the same as me, unless you attempt a reflash of the unit, then that's the only option.
    #9
  10. S321BAD
    Offline

    S321BAD Member

    Joined:
    Feb 11, 2013
    Messages:
    43
    Likes Received:
    2
    ok thanks NHN, seems fine at the minute, if it gives me any troubles i will give you a shout,
    #10

Share This Page