1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HEAVY STEERING

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by RallyX, Oct 7, 2010.

  1. RallyX
    Offline

    RallyX Flat Out VCDS Map User

    Joined:
    Apr 8, 2007
    Messages:
    143
    Likes Received:
    4
    [Oct 7, 2010]
    Does anyone else suffer with this problem? Wifes A4 Cab 2007 model is like a tank to drive, feels like only half the power steering is working. Tyre pressures are all correct. Is it the rack on the way out perhaps? Car has done 30000 miles. Thanks in advance for any answers.:ermm:
    #1
  2. Ads

    Ads

    [Sep 16, 2014]

  3. jdp1962
    Online

    jdp1962 Grumpy Old Moderator Staff Member Moderator

    Joined:
    May 26, 2003
    Messages:
    5,896
    Likes Received:
    859
    [Oct 7, 2010]
    Have you checked the fluid level in the power steering reservoir?
    #2
  4. RallyX
    Offline

    RallyX Flat Out VCDS Map User

    Joined:
    Apr 8, 2007
    Messages:
    143
    Likes Received:
    4
    [Oct 7, 2010]
    Yes, checked that and it is between half and full with engine running. Not sure where it is meant to be though.
    #3
  5. jdp1962
    Online

    jdp1962 Grumpy Old Moderator Staff Member Moderator

    Joined:
    May 26, 2003
    Messages:
    5,896
    Likes Received:
    859
    [Oct 7, 2010]
    There's a dipstick built into the screw-on cap. Also, I don't think you're supposed to check it when the engine is running.
    #4
  6. Thacker
    Offline

    Thacker New Member

    Joined:
    Sep 27, 2010
    Messages:
    19
    Likes Received:
    0
    [Oct 13, 2010]
    I have a similar problem on my B6 S4, it appears my servotronic solenoid is knackered, but only available with steering rack, £750 parts only!
    #5

Share This Page