1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Heater problem

Discussion in 'A4/S4 forum(B5 Chassis)' started by stub, Nov 7, 2009.

  1. stub
    Offline

    stub the matrix is comin

    Joined:
    Jan 19, 2009
    Messages:
    143
    Likes Received:
    0
    [Nov 7, 2009]
    hi all hope you can help.
    my heater just won't get hot. it seams to get warm then drops off a bit to tapid temp.

    i drain the water bout 2months ago when i was servicing it but i sure i got rid of any air locks. but could be wrong. what else could it be?:sos:
    #1
  2. Ads

    Ads

    [Oct 25, 2014]

  3. rasA4
    Offline

    rasA4 Four Rings Mafia Specialist

    Joined:
    Apr 16, 2003
    Messages:
    3,103
    Likes Received:
    1
    [Nov 7, 2009]
    Was the heater ok before you drained it? if so probably still have an air lock
    i know would have been difficult to know as the weather was ok.
    does the temp gauge ok in the centre when car has warmed up? could be the thermostat?
    what engine is your b5?
    #2
  4. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,716
    Likes Received:
    332
    [Nov 7, 2009]
    Sounds airlocky to me.

    To bleed the matrix (well to bleed the entire engine) you half remove one of the heater hoses so that the hole in the hose is exposed. Air will exit via the hole and eventually water will come out, at which point you refit the hose fully and redo the clamp.

    Should be obvious which hose has the hole, its longer, and the hole is highlighted in white.
    #3
  5. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,672
    Likes Received:
    296
    [Nov 7, 2009]
    Assuming the car heats up to 90 on the temp gauge then it has to be an airlock, or a clogged matrix. I would back flush the matrix and then put new g12 and water in, bleed, job done
    #4
  6. stub
    Offline

    stub the matrix is comin

    Joined:
    Jan 19, 2009
    Messages:
    143
    Likes Received:
    0
    [Nov 7, 2009]
    its a 1.8t b5. as far as i know the temp is ok. my gauge always reads 65-70. but i know why that is. i'm going to look at it on monday and hope i'll find whats wrong. thanks for all your help
    #5
  7. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,672
    Likes Received:
    296
    [Nov 7, 2009]
    Thermostat more than likely then, as the engine is barely warm tbh
    #6
  8. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,716
    Likes Received:
    332
    [Nov 7, 2009]
    The guage should sit at exactly 90c once its up to normal temperature.

    If your sat in traffic with it idling does it climb up to 90?
    #7
  9. stub
    Offline

    stub the matrix is comin

    Joined:
    Jan 19, 2009
    Messages:
    143
    Likes Received:
    0
    [Nov 8, 2009]
    the sender at the back off the engine is starting to play up. i was wondering if it was the themosat. but like i said i drained it all an was wondering if it is a air lock.
    #8
  10. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,716
    Likes Received:
    332
    [Nov 9, 2009]
    have you bled it as i described above?
    #9

Share This Page