1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Heater Noise and de-mister not working

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by stevemac, Feb 15, 2013.

  1. stevemac

    stevemac New Member

    Joined:
    Feb 15, 2013
    Messages:
    2
    Likes Received:
    0
    Hello I have a 2003 audi a4 2.0 estate, the front screen de-mister is not working but all others are and also the heater blower is making a noise, i was told it would need a whole new unit as the radio and heater are combined, or the brushes and a valve may need replacing
     
  2. Advert Guest Advertisement


  3. benjie

    benjie Well-Known Member

    Joined:
    Oct 10, 2009
    Messages:
    1,240
    Likes Received:
    301
    What kind of a noise? Is it like 'click, click' ??

    The radio and heater are separate units - if you can get your fingers under it, you can pull the air con unit out. If you take the glove box out (3x8mm bolts at the bottom and 3x8mm bolts in the top (where the glovebox door meets the dashboard). Look in the space and you will see a little black motors with different colour mechanisms attached to them. The green, long-armed one is the motot that controls the de-mister flap - push the cog up and that will open the defroster flap permanently, so at least you have air going up there to clear the windscreen.
     
  4. stevemac

    stevemac New Member

    Joined:
    Feb 15, 2013
    Messages:
    2
    Likes Received:
    0
    i suppose the sound isnt really a clicking sounds like the fan hitting plastic or something like that, i think it maybe the brushes worn it says they do go, would they make a noise if they go
     

Share This Page