1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Heater gremlins

haytch75 Sep 18, 2011

  1. haytch75

    haytch75 Member

    175
    16
    18
    Any advice appreciated.
    Last week my fans briefly started blowing hot air at me regardless of the temperature setting. It only happened once so I'm hoping its not the start of something expensive. Anyway, I took the glovebox off this morning and located the relevant motors, loosened them off, dusted down the linkages with a paintbrush, gave the linkages a good jiggle about, squirted with WD40 and reconnected. While I was in there I started the car up and started playing with the controls to see the mechanisms moving. The Green one didn't seem to move regardless of the temperature or fan speed selected. Is this normal? I should say that I didn't run the car up to running temperature.
    [​IMG]
     
  2. jbcalvin

    jbcalvin Member

    688
    21
    18
    The green one is for windscreen demist......
     
  3. haytch75

    haytch75 Member

    175
    16
    18
    That would explain it. Cheers JB.
     
  4. jbcalvin

    jbcalvin Member

    688
    21
    18
    Make sure you do the motor on the drivers side as well, lots of people forget this one, especially as it's a ***** to get to if it needs replacing...
     
  5. haytch75

    haytch75 Member

    175
    16
    18
    Cheers for that, didn't realise there was another. Pretty obvious when you think about it having dual climate control!
     
  6. haytch75

    haytch75 Member

    175
    16
    18
    Ba-jesus you weren't wrong about getting to it! Not a job for anyone that is a bit impatient and has sausage fingers.
     

Share This Page