1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Heated Seats and Rear Demister not working?

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Mollygoogle, Nov 24, 2012.

  1. Mollygoogle
    Offline

    Mollygoogle Member

    Joined:
    Aug 21, 2012
    Messages:
    172
    Likes Received:
    1
    [Nov 24, 2012]
    Recently the heated seats and heated rear screen have stopped working and the blowers don't kick in on the front demist. All the controls light up. All fuses appeared fine but I have swapped with known good ones just in case.

    There is a very good chance that this coincides with me fitting a new stereo so my first port of call is to check the wiring to the back of the control unit in the dash.

    The only thing that confuses me is that the drivers side heated mirror doesnt work, which I would expect, but the passengers side heated mirror does work??

    Could there be something else wrong? Surely the mirrors are on the same circuit as the rear screen?
    #1
  2. Ads

    Ads

    [Dec 23, 2014]

  3. Mollygoogle
    Offline

    Mollygoogle Member

    Joined:
    Aug 21, 2012
    Messages:
    172
    Likes Received:
    1
    [Nov 24, 2012]
    Pulled the controls from the dash, the plug nearest the driver was completely unplugged. Plugged it back in and the heated seats now work, front demist now works, hard to tell about rear demist and drivers mirror as yet
    #2
  4. Cabbyfan
    Offline

    Cabbyfan Member

    Joined:
    Jan 16, 2011
    Messages:
    698
    Likes Received:
    19
    [Nov 24, 2012]
    You should be fine. The mirrors get warm very quickly and I think come on with the rear window heater.
    #3

Share This Page