1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Headlights not working

mfalsey Jul 14, 2012

  1. mfalsey

    mfalsey New Member

    2
    0
    1
    Hi, My 2007 Audi A5 headlamps are not working.
    They are D3S HIDs.
    Head up display on dash is stating "Right dipped headlight / main beam headlight" and then "Left dipped headlight / main beam headlight".
    Neither sidelights, main beam or high beam are working. All other lights are. However, if i leave the indicator on (left or right) and switch engine on, the side light will illuminate (parking light).
    I have checked fuses in left and right door way and boot. I have changed both bulbs (like for like).
    I had it in at an independent Audi garage yesterday and they are stumped too!
    Dont know what to do next. Am i missing a relay or reset button?
    Help please. Martin
     
  2. hades-

    hades- Well-Known Member VCDS Map User

    9,482
    646
    113
    have you had a fault code scan yet ?
    thats what id do 1st
     
  3. mfalsey

    mfalsey New Member

    2
    0
    1
    Thanks for reply. Yes, I had it in at an independent Audi garage and they checked/cleared faults.

    Since then/above post, switch has also been replaced to no effect.

    Also, yesterday the drivers side light started working.

    I switched ballasts around and it may be them that are at fault.

    Currently have both ballasts off vehicle to air dry naturally. As I think with all the rain recently, moisture may have got in.

    Please let me know if there is anything else I can do?

    Thanks
     

Share This Page