1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hazard warning switch help!!

SPORT180 Feb 11, 2012

  1. SPORT180

    SPORT180 New Member

    25
    1
    1
    I have a A4 2.5 tdi quattro sport 2001 on the newer shape. I have a problem with my hazard warning lights that i can't fix and ran out of idears.

    You press the switch and nothing happens. I have changed the switch and did not solve.

    Both indcators work normally. If you press the button on the key fob they go on and off as they should. I can't find a fuse gone in the fuse box or one marked up for them. I have no wiring diagram that i can use to check or find the relay.I need hep as i need to fix this so my car will pass its mot.
     
  2. AudiLeon

    AudiLeon Well-Known Member VCDS Map User

    2,167
    147
    63
    I beleive the switch has the relay in it bud.
     
  3. CHEZ

    CHEZ moderately amusing Supporter

    4,114
    795
    113
    i would have suggested a relay at fault!
    but if the relay for your hazards are indeed located in the switch itself as blackquat suggests i personally would get the car scanned with vagcom to pinpoint an area!
     
  4. SPORT180

    SPORT180 New Member

    25
    1
    1
    Its the small hazard switch. 8E0 941 509 and i have already changed it
     
  5. SPORT180

    SPORT180 New Member

    25
    1
    1
    can't find a relay in back of the switch opened up the back only a small board that has the switch on it and the leds the it uses are soldered onto
     
    Last edited: Feb 11, 2012
  6. CHEZ

    CHEZ moderately amusing Supporter

    4,114
    795
    113
    someone will be here soon to assist brother!
    where is quattrojames when you need him?
    sounds like a relay dude! sit tight and the boys will be here to advise! :icon_thumright:
     
    SPORT180 likes this.
  7. marktdisport

    marktdisport Active Member

    1,195
    15
    38
    does the indicators work fine m8 and with key out the parking lights work ok ??? similar thing happened to my cupra and it was dust got into the indicator stalk causing it £3 tin of switch cleaner cured that fault......... my prob was my relay in the switch was clicking like crazy and hazard n/w intermittantly.............
     
  8. SPORT180

    SPORT180 New Member

    25
    1
    1
    Parking lights work ok with key out indicators work fine when used no excess clicking or sticking
     
  9. Turkster

    Turkster Bro.Paul 2.5TDI Quattro Sport

    2,796
    47
    48
    my moneys on the wiper stalk mate, they are used so often that the contacts get warn and can cause the hazzrds to stuff up, i had this on a passat B5.5 2001.
     
  10. marktdisport

    marktdisport Active Member

    1,195
    15
    38
    yeah turkster my thoughts excactly, this problem seems so similar to the issue i had with the cupra... and was told to clean the contacts with spray and couldnt believe how cheap the fix was
     
  11. AudiLeon

    AudiLeon Well-Known Member VCDS Map User

    2,167
    147
    63
    but the indicators are working? Its just the hazard light switch not working?
     
  12. SPORT180

    SPORT180 New Member

    25
    1
    1
    Indicators work ok just the hazard light switch is not working
     
  13. marktdisport

    marktdisport Active Member

    1,195
    15
    38
    its a common issue across the vag range they somehow connect or use the same relay somehow
     
  14. SPORT180

    SPORT180 New Member

    25
    1
    1
    :banghead: i have tried looking for a relay not in back of switch like earlier models dont have a wiring diagram or know were the relay could be located
     
  15. marktdisport

    marktdisport Active Member

    1,195
    15
    38
    but why would the relay be at fault when like stated the indicators work correctly and so does alarm on/off..... im just stating i had nearly the same issue as you and like you i tryed a hazard switch to no difference made and read of google the issue ppl have with vag's and its down to the dust and **** getting into the connections inside the stalk..... the fix was cheap a can of contact cleaner from maplins £3...... you may not have this fault but its very similar to the one i had thats what forums are for to share like minded info just thought its worth a shot.
     
  16. SPORT180

    SPORT180 New Member

    25
    1
    1
    I have cleaned out the indicator switch this has not fixed the problem. Does anyone know where the relay is or have a wiring diagram?
     
  17. SPORT180

    SPORT180 New Member

    25
    1
    1
    Can anyone help?
     
  18. CHEZ

    CHEZ moderately amusing Supporter

    4,114
    795
    113
    i dont know if yours is the same as mine, but i tried my hazards today and the relay sound seems to be behind the clocks or lower down from the clocks mate!
     
  19. SPORT180

    SPORT180 New Member

    25
    1
    1
    i have most of the dash out but cant find the relay had my hand up there and had a look were i could see at the back of the clocks only looks like connectors into the back
     
  20. SPORT180

    SPORT180 New Member

    25
    1
    1
    Does anyone have a wiring digram for this car that i can look at ? It might help me find the problem
     
  21. SPORT180

    SPORT180 New Member

    25
    1
    1
    The only power i have on the switch pin is 12v across pins 3 and 6 the reast are dead
     
  22. SPORT180

    SPORT180 New Member

    25
    1
    1
    Up date cannot find the cause .I have changed the switch with a brand new one. Switch pin 6 is 12v+ pin3 and pin 4 are earth pin 2 does not have power this seams to go the power control had this out checked the connections. Any one have a circuit diagram for this car?
     
    Last edited: Feb 19, 2012

Share This Page