1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hazard switch light and battery going flat

A4 nut Jan 14, 2010

  1. A4 nut

    A4 nut Member

    Messages:
    351
    Likes Received:
    0
    Trophy Points:
    16
    Hi my hazard switch light stops on and my battery drains is my switch faulty or is it telling me there is an under lying fault? Any ideas?
     
  2. J7USS

    J7USS Shuddup Foooool!!

    Messages:
    3,712
    Likes Received:
    39
    Trophy Points:
    48
    ... it stays on Permenantly you mean? they usually go off after couple mins after locking IIRC so if it is staying on all night then its faulty. Do you have a vag com??just incase it could be further field??
     
  3. A4 nut

    A4 nut Member

    Messages:
    351
    Likes Received:
    0
    Trophy Points:
    16
    stopping on all the time and some times flickers ,got vag com and you have seen the fault codes we got them down to 4 fault codes from over twenty on a thread i started last year, never solved the battery drain but now this light is stopping on so could this be the reason of my flat battery? The thread was( another battery problem i think)
     
  4. quattrojames

    quattrojames Moderator Staff Member Moderator Audi A6 Audi Avant Owner Group

    Messages:
    14,039
    Likes Received:
    565
    Trophy Points:
    113
    There has been a thread on this before (maybe yours?) as I remember going outside to see how long my hazard switch stayed illuminated for - (30 secs iirc).

    Since the new forum I cant find any of the original threads - I hope thats not permanent as there was a lot of very useful information in them ...
     
  5. J7USS

    J7USS Shuddup Foooool!!

    Messages:
    3,712
    Likes Received:
    39
    Trophy Points:
    48
    ^^ here here :detective2:
     
  6. A4 nut

    A4 nut Member

    Messages:
    351
    Likes Received:
    0
    Trophy Points:
    16
    Hi again its not the hazzard button ive tryed a new one but when i indicate or press the hazzard button it is very slow and irratic making me think its the relay but i cant find it. when i turn it on is sounds like it is coming from the clock pod or behind it any ideas where it is?
     
  7. brownie 25

    brownie 25 Member

    Messages:
    383
    Likes Received:
    9
    Trophy Points:
    18
    any update on this i have the same problem
     
  8. A4 nut

    A4 nut Member

    Messages:
    351
    Likes Received:
    0
    Trophy Points:
    16
    In the end i found the fault to be the climate unit draining the battery swapped it and all went fine
     
  9. saxonblue

    saxonblue Member

    Messages:
    298
    Likes Received:
    15
    Trophy Points:
    18
    HELLO EVERYONE
    i am a newbe here, but it sounds like me problem isnt, i too am having troble with the battery draining, and yep, my haserd warning light is staying on?
    i took the car for a good blast this morning, but when i went to start it up again later= nothing!!!!
    the man from the AA said the battery and everything else was fine, but theres a 1.8amp drain coming from somewhere
    Now, i am ok with lots of things on a motor, but electrics arnt my strongest point,
    any help would be nice as i am clueless about it????
     
  10. hartey

    hartey Member

    Messages:
    207
    Likes Received:
    3
    Trophy Points:
    18
    I too have this problem, thought about pulling one of the terminals off overnight to see if i can still start it, problem not cured i no, but at least i get the kids to school and me to work!
    Will this cause me any problems? Will get the problem fixed, but not till i no what it is!
     
  11. saxonblue

    saxonblue Member

    Messages:
    298
    Likes Received:
    15
    Trophy Points:
    18
    just a thought, you can get a battery saver kinda thingy from Argos, i have been told there ok
    i never sorted out the prob i had when mine did the same, altho a mate of mine has an a3 that did the same, it ended up that his locking was sticking, wd40 sortid it after having it to audi, pluss 3 loacal garages and an auto electrician.
     
  12. brownie 25

    brownie 25 Member

    Messages:
    383
    Likes Received:
    9
    Trophy Points:
    18
    mine was the convenience module, try unplugging it at night and see how it is then
     

Share This Page