1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Haldex system confusion

S3LOUD Feb 9, 2012

  1. <tuffty/>

    <tuffty/> Badger 5 Edition...Its all about the flow... Staff Member Moderator Audi S3

    21,140
    3,828
    113
    http://www.vaglinks.com/Docs/Audi/TT/Audi_TT_Haldex_SelfStudyGuide.pdf

    <tuffty/>
     
  2. A19quattro

    A19quattro Active Member

    605
    91
    28
    Anyone know if there is a Gen 2 version of that?
     
  3. thegoal007

    thegoal007 Another S3 owner....

    804
    26
    28
  4. Erf

    Erf Member

    243
    6
    18
    Thegoal sorry for any confusion, but most rear diffs for sale will also include the haldex unit (not the ecu) as did mine. I think when ppl talk about replacing the rear diff, they are generally talking about replacing the haldex as you rarely find just the haldex for sale.

    Gen 2 will not fit on the 8L vorshsprungdork.
     
  5. thegoal007

    thegoal007 Another S3 owner....

    804
    26
    28
    Ah, I see now. Did it also come with a pre charge pump or did u put your existing on on that too ?
     
  6. A19quattro

    A19quattro Active Member

    605
    91
    28
    Sorry, forgot I am in an 8l thread, mines an 8P (imposter).
     
  7. jimbob442

    jimbob442 Member

    59
    0
    6
    eznow - Mine is the exact same with the pump on vagcom showing hi all the time! Had any joy since you posted this?

    Cheers buddy
     
  8. Erf

    Erf Member

    243
    6
    18
    Chaps - it looks like my joy was short lived. I thought my problem was sorted, but it's back (or may not have gone in the first instance!). I went to get my rear diff oil and haldex oil / filter changed on Tuesday and then put fuse 31 back in, but the dragging is still there, but weirdly, just not as noticeable as before :3sadwalk:

    I'm now pretty sure my controller is goosed and the regulator is staying closed so there is maximum pressure on the clutch.

    I've ordered a replacement controller off ebay which should be arriving tomorrow so will provide an update then.

    Fun and games :drag:
     
  9. thegoal007

    thegoal007 Another S3 owner....

    804
    26
    28
    The controller is another part you've replaced previously.
    So I guess this is number 2 or is it the third one ?

    Also I thought you actually bought one of your previous controller off a member from this forum !
     
  10. s3dave

    s3dave TFSI Hybrid Supporter

    10,110
    736
    38
    Im not sure how many he bought, but one was from me, a low miler, im not sure what you are trying to say here,,,?
     
  11. Erf

    Erf Member

    243
    6
    18
    Not replaced the controller before! Replaced the pump with one from s3dave as said above, but that is fully functioning! Waiting for the Royal Mail with baited breath!
     
  12. thegoal007

    thegoal007 Another S3 owner....

    804
    26
    28
    S3 Dave, Sorry mate, 'I thought' wrongly as Erf has pointed out.

    Erf, well that really narrows it down if you get it working replacing the controller.
    Are you able to check what jimbob442 asked above. ?
     
  13. Erf

    Erf Member

    243
    6
    18
    New controller just arrived in the post and despite be assured it's off a facelift model, it looks like it's the wrong part!

    Anyone with a known working hadlex controller off a car with ESP, PLEASE PM ASAP!!!!!!
     
  14. neal98

    neal98 New Member

    1
    0
    1
    Hey folks,
    Mine is doing the same thing!! (2001 Audi TT) I have been everyplace asking, I have seen this problem quite a bunch but NEVER any answer! Anybody ever fix this problem? Issue is as follows, car is locked up in 4x4, binding, popping when turning, unplugging the Haldex controler makes it all go away. Vag-Com says pre-charge pump is staying in HI all the time, parking brake will not shut pump off. rear end has been swapped with a known good one, along with pump, controlers have been changed...with new....twice. problem still persists! Did everybody just give up and sell the cars?
     
  15. Erf

    Erf Member

    243
    6
    18
    I fixed mine eventually by replacing the controller but not until I'd replaced the diff twice, pre charge pump twice, front wheel speed sensors and numerous oil and filter changes! When replacing with second hand parts, there's no way of the knowing the replacement parts are defective too. This has been a very costly exercise for me!
     

Share This Page