1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Haldex problem

Discussion in 'A3/S3 Forum (8L Chassis)' started by edward_harris, Apr 1, 2008.

  1. edward_harris
    Offline

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    [Apr 1, 2008]
    Hey guys

    changed my haldex controller the weekend for a standard one, ever since then its only been front wheel drive. A little oil came out but not alot really. So i put the uprated one back on, and still its front wheel drive. Checked fuse number 31 looks fine. What else can it be? Also how do you check the haldex oil level and change it?
    Thanks
    #1
  2. Ads

    Ads

    [Sep 19, 2014]

  3. 1animal1
    Offline

    1animal1 The Clar!! it mouves!!! VCDS Map User

    Joined:
    Dec 27, 2007
    Messages:
    9,981
    Likes Received:
    31
    [Apr 1, 2008]
    eeerrrrrmmmmmm...... couldnt you ask a simple question
    #2
  4. edward_harris
    Offline

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    [Apr 1, 2008]
    Meaning its only front wheel drive 4wd dosent engage. i just get loads of wheel spin
    #3
  5. jojo
    Online

    jojo S3 Drift King! Staff Member Moderator

    Joined:
    Sep 4, 2003
    Messages:
    26,210
    Likes Received:
    1,661
    [Apr 1, 2008]
    I recommend you do a vagcom check on your car ed, sounds like a loose connection or something, if it was working before.
    #4
  6. edward_harris
    Offline

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    [Apr 2, 2008]
    anyone with VAGCOM in the area?!
    #5
  7. Dave_Bayern
    Offline

    Dave_Bayern Slipping at 3.5Krpm

    Joined:
    Sep 26, 2006
    Messages:
    1,914
    Likes Received:
    4
    [Apr 2, 2008]
    I have it (A4 Twyford/Wargrave) and Nick Evelry has it (Jct 11)
    #6
  8. Longman
    Offline

    Longman vassdignostics.co.uk

    Joined:
    Jul 5, 2007
    Messages:
    113
    Likes Received:
    0
    [Apr 2, 2008]
    I agree, VAG-COM will show if there are any communication problems between the ECU and the Haldex controller. Thats what I would expect to see.

    Have you got an ABS or Traction Control light on the dash?

    Remind me is fuse 31 one of the ones above the battery. If not I would check them too?
    #7
  9. edward_harris
    Offline

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    [Apr 2, 2008]
    no its the one one in the car. could it be one of those fuses then?! Are you about the weekend at all dave could you have a check over for me?! If it was low on oill would that cause it not to work?
    #8
  10. edward_harris
    Offline

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    [Apr 2, 2008]
    oh and no lights on the dash have come up!
    #9
  11. Dave_Bayern
    Offline

    Dave_Bayern Slipping at 3.5Krpm

    Joined:
    Sep 26, 2006
    Messages:
    1,914
    Likes Received:
    4
    [Apr 2, 2008]
    I'm about the weekend Ed, if you make your way over to mine I'll check it for you no problem. Send me a PM.

    Dave
    #10
  12. jojo
    Online

    jojo S3 Drift King! Staff Member Moderator

    Joined:
    Sep 4, 2003
    Messages:
    26,210
    Likes Received:
    1,661
    [Apr 3, 2008]

    I recommened you take it for a quick spin also and give us some feedback Dave. ;)
    #11
  13. Longman
    Offline

    Longman vassdignostics.co.uk

    Joined:
    Jul 5, 2007
    Messages:
    113
    Likes Received:
    0
    [Apr 3, 2008]
    Yeah, let us know how you get on.

    One of the large fuses under the bonnet over the battery is for ABS/TC communication. I looked at Ballcrushers car on here with a communication prob to the Haldex and ABS and it was a connection to that fuse that was shot.

    Well worth a check.

    V/C will show this anyway.
    #12
  14. edward_harris
    Offline

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    [Apr 3, 2008]
    Checked the fuses on top of the battery they were all ok! Guess we will have to see what VAG COM says!
    #13
  15. edward_harris
    Offline

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    [Apr 5, 2008]
    well dave check the vag com and after he cleared everything, no other faults came up. Still only front wheels drive tho. So i changed the haldex again for the standard one and changed the oil still not working! If its to low on oil would stop it working? Any other ideas?
    #14
  16. Dave_Bayern
    Offline

    Dave_Bayern Slipping at 3.5Krpm

    Joined:
    Sep 26, 2006
    Messages:
    1,914
    Likes Received:
    4
    [Apr 5, 2008]
    Only thing that came up on yours was brake light switch - intermittent.

    However, it also came up under the AWD control module, is that something that affects the haldex operation?
    #15
  17. edward_harris
    Offline

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    [Apr 5, 2008]
    what is the AWD module?!
    #16
  18. Dave B
    Offline

    Dave B REALITY?.... WHERE AM I AGAIN?.... WHO AM I AGAIN?

    Joined:
    Apr 12, 2007
    Messages:
    175
    Likes Received:
    0
    [Apr 5, 2008]
    Could it be that the AWD/Haldes systems can't see the brake applications to read how to apply 4wd ratio's?

    Dave
    #17
  19. simch
    Offline

    simch Active Member

    Joined:
    Feb 22, 2004
    Messages:
    2,028
    Likes Received:
    1
    [Apr 5, 2008]
    Well if the hadbrake is aplied, the handbrake has a switch which disables the haldex.

    Maybe its the same with the foot brake.....?
    #18
  20. Longman
    Offline

    Longman vassdignostics.co.uk

    Joined:
    Jul 5, 2007
    Messages:
    113
    Likes Received:
    0
    [Apr 6, 2008]
    Edward: AWD moduile is what controls the 4wd system (All wheel drive)

    I would definitely start with the brake light switch if it has come up on both controllers. It would make sense for it to diable the haldex if there was a problem like that.

    Its under the dash behind the pedal.
    #19
  21. edward_harris
    Offline

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    [Apr 6, 2008]
    but the brake lights are working fine! They were playing up before, so i adjusted it and works fine now!
    #20
  22. edward_harris
    Offline

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    [Apr 6, 2008]
    Then i would always have problems!!
    #21
  23. alijames
    Offline

    alijames Active Member

    Joined:
    Feb 10, 2008
    Messages:
    1,024
    Likes Received:
    0
    [Apr 6, 2008]
    Are we getting BORED again?

    Cheers,
    #22
  24. scott_johnson
    Offline

    scott_johnson Audiless

    Joined:
    Jan 24, 2008
    Messages:
    873
    Likes Received:
    1
    [Apr 30, 2008]
    Ed, how did you remove the haldex controller. is it easy???
    #23
  25. edward_harris
    Offline

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    [Apr 30, 2008]
    it is if you have a ramp and a ratchet with a pivot on the end other wise it can be tricky getting to the top bolt! I used a small allen key the first time! Why do you need to take yours off?!
    #24
  26. scott_johnson
    Offline

    scott_johnson Audiless

    Joined:
    Jan 24, 2008
    Messages:
    873
    Likes Received:
    1
    [May 1, 2008]
    got a fault thats always there from vagcom. haldex memory controll error. Was goin to wack it off and see if there was anything up with it!!
    #25
  27. edward_harris
    Offline

    edward_harris s3 gone now a shiney red evo 6

    Joined:
    Jan 11, 2007
    Messages:
    1,061
    Likes Received:
    2
    [May 1, 2008]
    it would prob be a electrical prob with it, and i guess the only way to sort it would be a new controller or get someone to repair yours!
    #26

Share This Page