1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Haldex pre pump help please

Ginge Jul 26, 2011

  1. Ginge

    Ginge It's never fast enough !

    192
    0
    16
    When I turn the ignition on you can hear the pump whirring, however it kind of unevenly pulses rather than a constant whirr.

    I'm having problems with my haldex at the moment, something that a new controller did not fix so I am trying to find a different solution to the problem.

    Thanks for any help guys :)
     
  2. superkarl

    superkarl MAN OF STEEL

    9,423
    2,382
    113
    Like a repetative buzz click buzz click buzzz?
    And youve replaced the controller too???
    What faults are you getting??
     
  3. superkarl

    superkarl MAN OF STEEL

    9,423
    2,382
    113
    Like a repetative buzz click buzz click buzzz?
    And youve replaced the controller too???
    What faults are you getting??
     
  4. Ginge

    Ginge It's never fast enough !

    192
    0
    16
    Yeah its repetitive but not regularly, so the buzzes and pauses are different lengths to each other. I have no 4wd at all and I get fault code that means no communication to haldex controller (think it is 01324 but can't 100% remember).

    I have also checked all the cables to the controller with no corrosion.
    I am now thinking that the controller I bought in working condition may not have been working OR maybe earthing strap ( which i forgot to check, or pre-charge pump or .... maybe it needs and oil and filter change ?? there was a tablespoon of oil that leaked when i changed the controller and it was as new, no buts or discolouration so I am officially stuck.
     

Share This Page