1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Haldex pre-charge pump, advice please

Discussion in 'A3/S3 Forum (8L Chassis)' started by HOTTIGGER, Aug 12, 2012.

  1. HOTTIGGER
    Offline

    HOTTIGGER Member

    Joined:
    Apr 14, 2012
    Messages:
    99
    Likes Received:
    0
    [Aug 12, 2012]
    hi all yet more bad new with my s3, my haldex 4x4 is not working, i did the usall checks for earth strap fuse, but mine is a preface lift and has no earth strap nor fuse,, any way i check the connection from the xaldex for corrosion and found the connection was full of oil, i think the oil seals have failed around the pump,,does this mean my haldex pre-charge pump is nackered? is there any way of fixing the pre-charge pump? will the haldex controller itself be ok ? or will i need a new pre-charge pump and haldex controller ? i also did a vag-com scan of the 4x4 system and the only thing it found wrong with it was a brake light switch, i reset it and in dint come back,, many thanks in advance.
    #1
  2. Ads

    Ads

    [Sep 20, 2014]

  3. jezzy
    Offline

    jezzy Member

    Joined:
    Oct 3, 2011
    Messages:
    762
    Likes Received:
    15
    [Aug 12, 2012]
    Hi mate
    I have the an s3 apy, think i posted last time you were investigating this.
    Your haldex pump is shot.
    The good news second hand one (look for s3 breaking) is around 60ish.
    You will have to drain the haldex oil to remove the pump.
    The pump is actually quite easy.2 to 3 bolts on the pump i cant remember.
    To free the pump, you will have use a screw driver on the rubber donut on the drive shaft to move it a bit out of the way(thats how i did mine).
    When your removing your pump you will see what i mean.
    It took me about a 1 hour and thats with the haldex drain.
    if you need any more info this thread is great VWVortex.com - Haldex pre-charge pump removal / disassembly PIC HEAVY
    #2
    HOTTIGGER likes this.
  4. HOTTIGGER
    Offline

    HOTTIGGER Member

    Joined:
    Apr 14, 2012
    Messages:
    99
    Likes Received:
    0
    [Aug 12, 2012]
    hi jezzy m8, yes u did reaply to my last thread many thanks to you again for reaplying, you have bin really helpfull next time ur near i owe u a pint,, so my pre-charge pump is nackered, will the haldex conntroller itself be ok ? will it have done any other damage with the pump bing nackered? thanks again jezzy..
    #3
  5. jezzy
    Offline

    jezzy Member

    Joined:
    Oct 3, 2011
    Messages:
    762
    Likes Received:
    15
    [Aug 12, 2012]
    my haldex controller was fine and is still working.
    My pump was gone for about six months, i thought my clutch was gone and was just waiting for it to go.
    Then realised my haldex pump was shot after reading in depth about them.
    The above thread was so helpful, it explained everything.
    i cant say for certain your controller is shot, you will have to change the pump and find out.
    But if nothing comes up on vag com about your haldex controller i would imagine it would be fine.
    Sourcing the pump an be arse to say the least.
    people selling complete back end for 150 then wanting 120 for just the pump.
    i bought one from a member on here who was breaking in the end, its been fine.
    There about £400 new
    #4
  6. ron burgandy
    Offline

    ron burgandy Member

    Joined:
    Jan 7, 2011
    Messages:
    128
    Likes Received:
    15
    [Nov 3, 2013]
    I'm having this problem, the front wheels still keep spinning when it's wet or when's its on gravel it's still got 2 months left on the warranty so hopefully I'll get it sorted fingers crossed the dealers haven't been great with me so far. We will see what happens
    #5

Share This Page