1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HALDEX NOT WORKING

Discussion in 'A3/S3 Forum (8L Chassis)' started by bogard, May 13, 2010.

  1. bogard
    Offline

    bogard New Member

    Joined:
    Apr 14, 2009
    Messages:
    18
    Likes Received:
    0
    help i got no 4 wheel drive,had it scanned no faults reported and haldex communicating with ecu and abs anyone know what to check next
    thanks
    #1
  2. sportstractor
    Offline

    sportstractor Chugger Regional Rep

    Joined:
    Nov 25, 2009
    Messages:
    2,715
    Likes Received:
    31
    earth strap on rear diff?
    #2
  3. bogard
    Offline

    bogard New Member

    Joined:
    Apr 14, 2009
    Messages:
    18
    Likes Received:
    0
    Thanks for the idea, the earth strap is connected also on measuring blocks the brake light and handbrake switch work.
    #3
  4. barters3
    Offline

    barters3 Member

    Joined:
    May 21, 2008
    Messages:
    438
    Likes Received:
    0
    It was the pre charge pump that failed on mine and it prevented the haldex unit from operating completly. It's the small pump with a black plastic tube and plug in connections. It won't show any fault codes if it has packed up. It's in the region of 250 quid new and nobody seems to want to split one from the rear diffs that are for sale on eBay. It would be worth contacting a vag tuner in Bridgwater called tsr performance (details on google) they do a lot of 1.8t conversions and the guy informed me whilst i was having other work done there that they have got complete rear diffs just lying around. So maybe worth a try. Good luck.
    #4
  5. bogard
    Offline

    bogard New Member

    Joined:
    Apr 14, 2009
    Messages:
    18
    Likes Received:
    0
    Thanks very much for replying,does anybody know how to test if the pre charge pump is working or not?
    #5
  6. barters3
    Offline

    barters3 Member

    Joined:
    May 21, 2008
    Messages:
    438
    Likes Received:
    0
    I don't know how to test it I'm afraid. If you do a search there was a thread on here not so long ago on a similar subject. However I think most of the sugestions have been covered in this thread. Worth checking the fuse for the haldex if you haven't already. If you do end up changing the pump you will need some replacement haldex oil.
    #6
  7. AudiS3-Turbo
    Offline

    AudiS3-Turbo Member

    Joined:
    Mar 28, 2010
    Messages:
    578
    Likes Received:
    10
    you can test the pump is working with vagcom under simulation tests? cant remember,i was playing around in vagcom and found this,heard mine come in and out etc.
    #7
  8. AudiS3-Turbo
    Offline

    AudiS3-Turbo Member

    Joined:
    Mar 28, 2010
    Messages:
    578
    Likes Received:
    10
    #8
  9. bogard
    Offline

    bogard New Member

    Joined:
    Apr 14, 2009
    Messages:
    18
    Likes Received:
    0
    i tried the output tests but nothing seemed to happen but a little click.
    if a rear wheel is jacked up then the output clutch is engaged should the wheel be locked or spin ?
    #9
  10. AudiS3-Turbo
    Offline

    AudiS3-Turbo Member

    Joined:
    Mar 28, 2010
    Messages:
    578
    Likes Received:
    10
    dont know what will happen if jacked up,i suspect even with the pump working and the coupling engaged it will still act like a normal open diff and with one wheel in the air still turn regardless,mine i could hear the pump working when sat in the car,if yours is not making any noise when activated in output tests its probably dead or a bad connection.
    #10
  11. bogard
    Offline

    bogard New Member

    Joined:
    Apr 14, 2009
    Messages:
    18
    Likes Received:
    0
    cheers for the help, i think i will have to be climbing under and having a closer look
    #11
  12. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    Agreed, the fuse for the Haldex would be my first port of call, followed by the plug for it - I believe it's on the engine bay somewhere.
    #12
  13. domas
    Offline

    domas New Member

    Joined:
    Aug 5, 2010
    Messages:
    4
    Likes Received:
    0
    hi i had the same problem with the haldex pre charge pump and in vw or audi these little pumps cost 400 quid i i was looking to get that pump for a month and i found company or something like that i sended them my old pump and they replaced new engine and other parts needed for that pump it costed me only 150 quid and i got new pre charge pump new engine new seals and now almost three years and no rpoblems at all
    #13
  14. domas
    Offline

    domas New Member

    Joined:
    Aug 5, 2010
    Messages:
    4
    Likes Received:
    0
    and i forgot i think they fixing haldex computers and does all sorts with the haldex
    #14
  15. domas
    Offline

    domas New Member

    Joined:
    Aug 5, 2010
    Messages:
    4
    Likes Received:
    0
    to test pre charge pump just take it of and do bench test with car batery
    #15
  16. domas
    Offline

    domas New Member

    Joined:
    Aug 5, 2010
    Messages:
    4
    Likes Received:
    0
    #16
  17. S3KO4
    Offline

    S3KO4 Member

    Joined:
    Aug 15, 2009
    Messages:
    850
    Likes Received:
    2
    most of the time is the pump, cost nearly £120 second hand, I changed 2 controllers before this with no joy, I could hear it working even if the car is not moving. the wheels should spin if the car is jacked.
    #17
  18. The Slug
    Offline

    The Slug Active Member

    Joined:
    Nov 4, 2004
    Messages:
    1,870
    Likes Received:
    0
    Have you checked the fuse?
    #18

Share This Page